Bug 1828280 - Drop deprecated functionality in oc 4.5
Summary: Drop deprecated functionality in oc 4.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 13:47 UTC by Maciej Szulik
Modified: 2020-07-13 17:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 310 0 None closed Bug 1828280: Drop deprecated commands and flags 2020-06-24 01:21:59 UTC
Github openshift origin pull 24813 0 None closed Bug 1828280: Remove deprecated flags and commands from test-cmd 2020-06-24 01:21:59 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:09 UTC

Description Maciej Szulik 2020-04-27 13:47:11 UTC
The following commands and/or flags needs to be dropped in 4.5:

- oc policy can-i command deprecated in 3.9 (openshift/origin@73338c4), users should use oc auth can-i instead
- oc new-app --image and oc new-build --image flags deprecated in 3.2 (openshift/origin@6517d76), users should use --image-stream instead
- oc process -t flag deprecated in 3.11 (openshift/origin@6a8cc0b), users should use --template instead
- oc process --output-version flag deprecated in 3.11 (openshift/origin@6a8cc0b), the flag was already ignored
- oc set deployment-hook -v flag deprecated in 3.11 (openshift/origin@2fcf185), users should use --volumes instead
- oc set volumes --list flag deprecated in 3.3 (openshift/origin@af79d7d), oc set volumes w/o flags will list volumes
- oc status -v and oc status --verbose flags deprecated in 3.11 (openshift/origin@2fcf185), users should use --suggest instead

Comment 3 zhou ying 2020-05-06 03:38:10 UTC
Confirmed  with latest oc , the issue has fixed:
[root@dhcp-140-138 ~]# oc version -o yaml
clientVersion:
  buildDate: "2020-05-02T15:23:53Z"
  compiler: gc
  gitCommit: 29e9a330f0ab0eed17b5ba6a8cc198ccc4332567
  gitTreeState: clean
  gitVersion: 4.5.0-202005021517-29e9a33
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

Comment 4 errata-xmlrpc 2020-07-13 17:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.