Bug 1828402 - Cannot block UI features from Operator Annotation
Summary: Cannot block UI features from Operator Annotation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 16:33 UTC by Bipul Adhikari
Modified: 2020-07-13 17:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5114 0 None closed Bug 1828402: Add support for array of flags 2020-06-24 01:22:43 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:09 UTC

Description Bipul Adhikari 2020-04-27 16:33:19 UTC
Description of problem:
UI should show Independent Mode Installation flow based on the annotation provided in OCS Operator.

Version-Release number of selected component (if applicable):


How reproducible: 1/1


Steps to Reproduce:
1. Go to Installed Operators -> Create Storage Cluster

Actual results:
 The radio button for Independent Mode is seen even when annotation for it is not present in OCS operator CSV.

Expected results:
Should not present(the radio button)


Additional info:

Comment 3 Bipul Adhikari 2020-06-15 08:59:56 UTC
More Information regarding this can be found at https://github.com/openshift/console/tree/master/frontend/packages/ceph-storage-plugin#ocs-ui-features. 
This BZ was added to achieve this blocking mechanism in OCS 4.5.

Comment 5 errata-xmlrpc 2020-07-13 17:31:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.