Bug 1828478 - Action menu should be "Add Health Checks" when no probes is added
Summary: Action menu should be "Add Health Checks" when no probes is added
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 19:33 UTC by Vikram Raj
Modified: 2020-07-13 17:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
add health checks (195.73 KB, image/png)
2020-05-04 07:53 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5201 0 None closed Bug 1828478: Action menu should be 'Add Health Checks' when no probes is added 2020-06-24 01:24:08 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:11 UTC

Description Vikram Raj 2020-04-27 19:33:53 UTC
Description of problem:
Action menu for D/DC/DS/SS/Kn services should be "Add Health Checks" when no probes have been added and "Edit Health Checks" when probes is present.


How reproducible:


Steps to Reproduce:
1. Create an application using add flow.
2. Click on the node of the created application. and open the Actions menu and see Edit Health Checks option is there. It says Edit Health checks even if health checks probes is not added for the resource

Actual results:
- Action menu option is always "Edit Health Checks".

Expected results:
- Action menu should be "Add Health Checks" if not probes is added and "Edit Health Checks" when probes has been added.

Additional info:

Comment 3 Gajanan More 2020-05-04 07:53:34 UTC
Created attachment 1684717 [details]
add health checks

Comment 4 Gajanan More 2020-05-04 07:55:48 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-05-03-172622
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared
Marking this as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.