Bug 1828479 - topology find filter is saved across sessions and namespaces
Summary: topology find filter is saved across sessions and namespaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 19:36 UTC by Rohit Rai
Modified: 2020-07-13 17:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5202 0 None closed Bug 1828479: Move topology search query from localstorage to url param 2020-07-03 10:05:31 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:11 UTC

Description Rohit Rai 2020-04-27 19:36:54 UTC
Description of problem: Unlike the display filters, the find by name query text is very specific to a namespace context. As a user I wouldn't expect for the same search string to be present when changing namespaces.

The name filter of resource details pages are not saved across sessions or pages. It is however saved in the URL such that the user can go back in history and have the same name filter applied.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Go to topology and search a node
2. Close the browser tab and reopen topology page

Actual results: You see the search filter retaining the previous session


Expected results: Search filter should not be saved across sessions or while changing the namespace


Additional info:

Comment 3 Gajanan More 2020-05-05 11:20:50 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-05-04-113741
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified

Comment 4 errata-xmlrpc 2020-07-13 17:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.