Bug 1828488 - Rebase pacemaker in 8.3 on upstream 2.0.4
Summary: Rebase pacemaker in 8.3 on upstream 2.0.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: pacemaker
Version: 8.3
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: 8.3
Assignee: Ken Gaillot
QA Contact: cluster-qe@redhat.com
Steven J. Levine
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 19:57 UTC by Ken Gaillot
Modified: 2020-11-04 21:29 UTC (History)
6 users (show)

Fixed In Version: pacemaker-2.0.4-2.el8
Doc Type: Enhancement
Doc Text:
.`pacemaker` rebased to version 2.0.4 The Pacemaker cluster resource manager has been upgraded to upstream version 2.0.4, which provides a number of bug fixes.
Clone Of:
Environment:
Last Closed: 2020-11-04 04:00:53 UTC
Type: Component Upgrade
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:4804 0 None None None 2020-11-04 04:01:08 UTC

Description Ken Gaillot 2020-04-27 19:57:37 UTC
Upstream is starting the release process for 2.0.4 soon. The new version will fix at least 6 rhbz's.

Comment 1 Ken Gaillot 2020-06-11 16:34:44 UTC
QA: This rebase includes fixes that had separate BZs for RHEL 7 but do not have separate BZ for RHEL 8:

* Bug 1458953 improved disabled resources count
* Bug 1760669 transitive group colocation scores

Comment 7 Markéta Smazová 2020-09-24 16:30:42 UTC
Disabled resource count improvement (which had its own Bug 1458953 in rhel7) verified in pacemaker-2.0.4-6.el8.

crm_resource cleanup/refresh man/help text update (was Bug 1758969 in rhel7) verified in pacemaker-2.0.4-6.el8.

Comment 8 Patrik Hagara 2020-09-24 22:36:09 UTC
I've checked that the transitive group colocation scores behave as expected (see the RHEL-7 BZ verification comment https://bugzilla.redhat.com/show_bug.cgi?id=1760669#c15 for instructions).

Regressions tests look good, marking verified in pacemaker-2.0.4-6.el8

Comment 11 errata-xmlrpc 2020-11-04 04:00:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (pacemaker bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:4804


Note You need to log in before you can comment on or make changes to this bug.