Bug 1828550 - Cannot deprecate old versions of CRDs
Summary: Cannot deprecate old versions of CRDs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Daniel Sover
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 20:09 UTC by Daniel Sover
Modified: 2020-07-13 17:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1504 0 None closed Bug 1828550: safely deprecate stored versions of CRDs 2020-11-11 07:47:34 UTC
Github operator-framework operator-lifecycle-manager pull 1529 0 None closed [WIP] Bug 1828550: add storage migrator to OLM 2020-11-11 07:47:34 UTC
Github operator-framework operator-lifecycle-manager pull 1535 0 None closed Bug 1828550: add check for storage version changes when installing CRDs 2020-11-11 07:47:34 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:11 UTC

Comment 12 errata-xmlrpc 2020-07-13 17:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.