Bug 1828591 - Preview Badge Appears Double on Search
Summary: Preview Badge Appears Double on Search
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-27 21:02 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:31:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Two Badges - Pipeline Resources (28.13 KB, image/png)
2020-04-27 21:08 UTC, Andrew Ballantyne
no flags Details
dev preview badges fix (105.52 KB, image/png)
2020-04-30 07:48 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5227 0 None closed Bug 1828591: Fix heading issues in console and cleanup CSS for filters 2021-02-09 11:17:43 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:11 UTC

Description Andrew Ballantyne 2020-04-27 21:02:37 UTC
Description of problem:
On the Search page, when looking at a resource that has a Dev or Tech Preview badge, it appears twice.

Version-Release number of selected component (if applicable):
OpenShift 4.5

How reproducible:


Steps to Reproduce:
1. Head over to the search page (dev or admin perspectives)
2. Search for a resource that uses a badge (ie, Pipeline Resources)

Actual results:
See two badges around the "Create <Resource>" button. Once Tech Preview is supported by the Dev Perspective, Pipeline Run will have two Tech Preview badges and no create button (as we don't allow direct creating of Pipeline Run CRs.

Expected results:
See only one badge for any given resource.

Additional info:
Likely related to the work done here: https://github.com/openshift/console/pull/5080

Comment 1 Andrew Ballantyne 2020-04-27 21:08:12 UTC
Created attachment 1682286 [details]
Two Badges - Pipeline Resources

Comment 2 ralpert 2020-04-29 17:41:47 UTC
*** Bug 1827976 has been marked as a duplicate of this bug. ***

Comment 5 XiaochuanWang 2020-04-30 07:48:21 UTC
Created attachment 1683208 [details]
dev preview badges fix

Comment 6 XiaochuanWang 2020-04-30 07:49:39 UTC
On 4.5.0-0.nightly-2020-04-30-023404, the Dev Preview Badge is well displays on the right side of page. 
Attached the screenshot for the fix. This could be Verified.

Comment 7 errata-xmlrpc 2020-07-13 17:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.