Bug 1828602 - Upgrade Pipelines to TechPreview
Summary: Upgrade Pipelines to TechPreview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
low
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1828955
TreeView+ depends on / blocked
 
Reported: 2020-04-27 21:36 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1828955 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:31:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Upgrade Pipelines to TechPreview1 (6.35 KB, image/png)
2020-05-03 22:34 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview2 (4.99 KB, image/png)
2020-05-03 22:34 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview3 (7.07 KB, image/png)
2020-05-03 22:35 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview4 (4.31 KB, image/png)
2020-05-03 22:36 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview5 (7.72 KB, image/png)
2020-05-03 22:36 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview6 (8.20 KB, image/png)
2020-05-03 22:37 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview7 (6.12 KB, image/png)
2020-05-03 22:37 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview8 (9.19 KB, image/png)
2020-05-03 22:38 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview9 (33.95 KB, image/png)
2020-05-03 22:38 UTC, spathak@redhat.com
no flags Details
Upgrade Pipelines to TechPreview10 (18.94 KB, image/png)
2020-05-03 22:38 UTC, spathak@redhat.com
no flags Details
Pipelines with Tech Preview badge (86.65 KB, image/png)
2020-05-04 05:46 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5002 0 None closed Bug 1828602: Pipelines TechPreview Badges / ApiVersion 2020-09-07 21:39:42 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:32:11 UTC

Description Andrew Ballantyne 2020-04-27 21:36:08 UTC
Description of problem:
Operator has adopted a TechPreview set of resources and the client is not properly matching those resources with our internal models.

Version-Release number of selected component (if applicable):
OpenShift Pipelines Operator 0.11+
OpenShift Console 4.5 & 4.4

Steps to Reproduce:
Once the 0.11+ Operator is installed (also works for the Productized Operator which will have an ocp44 channel)

Via the Search Page:
1. Navigate to the Search page
2. Search for Pipelines (note it does not have a badge)

Via creating a resource:
1. Using the masthead "+" button and create a v1beta1 Pipeline resource
2. On submit, you'll be redirect to the resource that was created (v1beta1 resource page does not exist)

Actual results:
You'll see a page without a badge

Expected results:
You should see the Tech Preview badge

Additional info:
This will only impact Pipelines, Pipeline Runs, Tasks, Task Runs and Cluster Tasks... the resources that went to v1beta1.

Comment 4 spathak@redhat.com 2020-05-03 22:34:08 UTC
Created attachment 1684572 [details]
Upgrade Pipelines to TechPreview1

Comment 5 spathak@redhat.com 2020-05-03 22:34:37 UTC
Created attachment 1684573 [details]
Upgrade Pipelines to TechPreview2

Comment 6 spathak@redhat.com 2020-05-03 22:35:15 UTC
Created attachment 1684574 [details]
Upgrade Pipelines to TechPreview3

Comment 7 spathak@redhat.com 2020-05-03 22:36:00 UTC
Created attachment 1684575 [details]
Upgrade Pipelines to TechPreview4

Comment 8 spathak@redhat.com 2020-05-03 22:36:32 UTC
Created attachment 1684576 [details]
Upgrade Pipelines to TechPreview5

Comment 9 spathak@redhat.com 2020-05-03 22:37:03 UTC
Created attachment 1684577 [details]
Upgrade Pipelines to TechPreview6

Comment 10 spathak@redhat.com 2020-05-03 22:37:33 UTC
Created attachment 1684578 [details]
Upgrade Pipelines to TechPreview7

Comment 11 spathak@redhat.com 2020-05-03 22:38:00 UTC
Created attachment 1684579 [details]
Upgrade Pipelines to TechPreview8

Comment 12 spathak@redhat.com 2020-05-03 22:38:22 UTC
Created attachment 1684580 [details]
Upgrade Pipelines to TechPreview9

Comment 13 spathak@redhat.com 2020-05-03 22:38:46 UTC
Created attachment 1684581 [details]
Upgrade Pipelines to TechPreview10

Comment 14 spathak@redhat.com 2020-05-03 22:40:29 UTC
Verified on build: 4.5.0-0.nightly-2020-05-03-172622
Browser version: firefox69

Comment 15 Gajanan More 2020-05-04 05:46:39 UTC
Created attachment 1684640 [details]
Pipelines with Tech Preview badge

Comment 16 errata-xmlrpc 2020-07-13 17:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.