Bug 1828939 - jenkins oauth integration is broken on JDK 11
Summary: jenkins oauth integration is broken on JDK 11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.4.z
Assignee: Akram Ben Aissi
QA Contact: Jitendar Singh
URL:
Whiteboard:
: 1784147 (view as bug list)
Depends On: 1783530
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-28 15:41 UTC by jawed
Modified: 2020-06-23 18:01 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1783530
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift jenkins pull 1053 None closed [release-4.4] Bug 1828939: set default java version to jdk 11 2020-07-05 19:39:47 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:42 UTC

Comment 3 Jitendar Singh 2020-06-16 22:32:56 UTC
 ✘ jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates  ➦ 1c19ede  oc project jenkins-test
Now using project "jenkins-test" on server "https://api.jenkins-bugs-ver-4.4.8.qe.devcluster.openshift.com:6443".
 jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates  ➦ 1c19ede  oc get pods
NAME               READY   STATUS      RESTARTS   AGE
jenkins-1-build    0/1     Completed   0          36m
jenkins-1-deploy   0/1     Completed   0          27m
jenkins-1-tszxk    1/1     Running     0          27m
 jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates  ➦ 1c19ede  oc rsh jenkins-1-tszxk
sh-4.2$ java version
Error: Could not find or load main class version
Caused by: java.lang.ClassNotFoundException: version
sh-4.2$ java -version
openjdk version "11.0.7" 2020-04-14 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.7+10-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.7+10-LTS, mixed mode, sharing)

=====================================================================================
-default JAVA version set to 11
-oauth tested
-pipeline build successful
=======================================================================================
VERIFIED

Comment 5 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580

Comment 6 Akram Ben Aissi 2020-06-23 18:01:57 UTC
*** Bug 1784147 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.