Bug 1829052 - Operand list view - “Version” field always shows "Unknown" and makes CR or UI look broken
Summary: Operand list view - “Version” field always shows "Unknown" and makes CR or UI...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-28 19:13 UTC by tony.wu
Modified: 2020-07-13 17:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: We are howing "Unknown" for the operand's "Version". Since “Version” is not a common spec field of Custom Resource. Consequence: Showing "Unknown", which makes UI look broken and in fact it doesn't. Fix: Remove the Version column. Result: No Version column, to confuse user.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
ArgoCD_CR_list_view_always_shows_Unknown_version (300.89 KB, image/png)
2020-04-28 19:13 UTC, tony.wu
no flags Details
Operand List View (164.41 KB, image/png)
2020-05-22 05:58 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5310 None closed Bug 1829052: Remove non-general 'Version' field from Installed Operators list page 2020-06-24 01:27:47 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:32:47 UTC

Description tony.wu 2020-04-28 19:13:36 UTC
Created attachment 1682582 [details]
ArgoCD_CR_list_view_always_shows_Unknown_version

Created attachment 1682582 [details]
ArgoCD_CR_list_view_always_shows_Unknown_version

On Operand list view, since “Version” is not a common spec field of Custom Resource ('spec.version'), it shouldn't be always present and only showing "Unknown", which makes UI look broken and in fact it doesn't.

Version-Release number of selected component (if applicable):
OCP 4.4

How reproducible:
100%

Steps to Reproduce:
1. Go to “OperatorHub” view, install “ArgoCD” Operator
2. Go to “Installed Operators” view, create “ArgoCD” instance
3. See “ArgoCD” list view

Actual results:
See “ArgoCD” list view: “Version” field always show “Unknown” since 'spec.version’ doesn’t exist.

Expected results:
Shouldn’t be always showing 'spec.version’ field.
Suggests removing the “Version” field and add “Created” field (from ‘metadata.creationTimestamp’ in YAML) as the right-most column.

Comment 1 bpeterse 2020-04-28 21:03:36 UTC
We can look at a backport to 4.4.z.

Comment 2 Jakub Hadvig 2020-04-29 08:32:39 UTC
Looked into the implementation and it turned out that the "Last Updated" field
is already using the `obj.metadata.creationTimestamp` based on:
https://github.com/openshift/console/blob/master/frontend/packages/operator-lifecycle-manager/src/components/operand/index.tsx#L170-L175

I would suggest to rename the field header to reflect on its data.
Regarding the issue with the `Version` field I would either keep it as is or
remove it complete.

Ben thoughts ?

Comment 3 tony.wu 2020-05-05 16:35:57 UTC
Nice! Didn't notice 'Last Updated' has been already there as tableColumnClasses[5] since it's not shown on the screens not wide enough.
Agree on remove the non-gerneral `Version` field completely, and this would help expose the Last Updated timestamp on narrower res. Thanks!

Comment 4 bpeterse 2020-05-05 19:30:28 UTC
+!

Comment 7 Yadan Pei 2020-05-22 05:58:55 UTC
Created attachment 1690966 [details]
Operand List View

Now Operand List table only has Name, Kind, Status, Labels, Last Updated, Version column is removed

Verified on 4.5.0-0.nightly-2020-05-21-135919

Comment 8 errata-xmlrpc 2020-07-13 17:32:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.