Bug 1829236 - Missing e2e tests for customURL feature in console-operator
Summary: Missing e2e tests for customURL feature in console-operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 09:22 UTC by Jakub Hadvig
Modified: 2020-07-13 17:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: missing e2e tests for the console's customURL feature in the console-operator. Consequence: Additional changes to the customURL logic could lead to regressions. Fix: Add e2e test for the customURL. Result: CI will test setting and unsetting of the customURL to prevent regressions when merging changes into the console-operator repo.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 416 0 None closed Bug 1829236: CustomURL e2e 2020-09-04 13:09:55 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:01 UTC

Description Jakub Hadvig 2020-04-29 09:22:32 UTC
Description of problem:
We are missing e2e tests for the console's customURL feature in the console-operator. Need to provide them in order to prevent feature regression.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Yadan Pei 2020-05-09 05:50:32 UTC
I think this bug can be verified since PR was already merged https://github.com/openshift/console-operator/blob/master/test/e2e/custom_url_test.go

Comment 4 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.