Bug 1829244 - code_verb:apiserver_request_total:increase30d is failing to evaluate
Summary: code_verb:apiserver_request_total:increase30d is failing to evaluate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 09:43 UTC by Matthias Loibl
Modified: 2020-07-13 17:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 775 0 None closed Bug 1829244: Update kubernets-mixin to get improvements for kube-apiserver-availability 2020-10-01 17:55:29 UTC
Github openshift cluster-monitoring-operator pull 781 0 None closed Bug 1829244: update kubernetes-mixin to latest release-0.4 branch 2020-10-01 17:55:28 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:01 UTC

Description Matthias Loibl 2020-04-29 09:43:17 UTC
Description of problem:
https://github.com/coreos/kube-prometheus/issues/503

Version-Release number of selected component (if applicable):
4.5

How reproducible:
It's reproducable with an Kube APIServer that has enough samples scraped across a few days / weeks.

It has already been fixed by me upstream:
https://github.com/kubernetes-monitoring/kubernetes-mixin/pull/403

See GitHub issue and discussions for more details.

Comment 4 Junqi Zhao 2020-05-08 02:59:16 UTC
Tested with 4.5.0-0.nightly-2020-05-07-144853, code_verb:apiserver_request_total:increase30d record rules are updated with the fix

Comment 5 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.