Bug 1829263 - cluster autoscaler operator CRDs should be using apiextensions.k8s.io/v1
Summary: cluster autoscaler operator CRDs should be using apiextensions.k8s.io/v1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Alberto
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 10:16 UTC by Alberto
Modified: 2020-07-13 17:33 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-autoscaler-operator pull 148 0 None closed Bug 1829263: Bump apiextensions 2020-06-24 01:28:11 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:01 UTC

Description Alberto 2020-04-29 10:16:10 UTC
Description of problem:
cluster autoscaler operator CRDs should be using apiextensions.k8s.io/v1. It's currently using cluster autoscaler operator CRDs should be using apiextensions.k8s.io/v1betav1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Jianwei Hou 2020-05-07 03:26:00 UTC
Verified in 4.5.0-0.nightly-2020-05-06-003431

oc get crd clusterautoscalers.autoscaling.openshift.io -o=jsonpath="{.apiVersion}"
apiextensions.k8s.io/v1%
oc get crd machineautoscalers.autoscaling.openshift.io -o=jsonpath="{.apiVersion}"
apiextensions.k8s.io/v1%

Comment 4 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.