Bug 1829320 - cluster-csi-snapshot-controller-operator shows ugly event on version change
Summary: cluster-csi-snapshot-controller-operator shows ugly event on version change
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jan Safranek
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 11:41 UTC by Jan Safranek
Modified: 2020-07-13 17:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-csi-snapshot-controller-operator pull 36 0 None closed Bug 1829320: UPSTREAM: 787: Fix ClusterOperator event when version changes 2021-01-01 05:32:21 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:01 UTC

Description Jan Safranek 2020-04-29 11:41:43 UTC
This event is created in openshift-cluster-storage-operator during cluster installation:

145m        Normal    OperatorStatusChanged             deployment/csi-snapshot-controller-operator             Status for clusteroperator/csi-snapshot-controller changed: {"conditions":[{"type":"Degraded","status":"False","lastTransitionTime":"2020-04-29T09:14:20Z","reason":"AsExpected"},{"type":"Progressing","status":"Unknown","lastTransitionTime":"2020-04-29T09:14:20Z","reason":"NoData"},{"type":"Available","status":"Unknown","lastTransitionTime":"2020-04-29T09:14:20Z","reason":"NoData"},{"type":"Upgradeable","status":"Unknown","lastTransitionTime":"2020-04-29T09:14:20Z","reason":"NoData"}],"

A: relatedObjects":[{"group":"","resource":"namespaces","name":"openshift-cluster-storage-operator"},{"group":"","resource":"namespaces","name":"openshift-cluster-storage-operator"},{"group":"operator.openshift.io","resource":"csisnapshotcontrollers","name":"cluster"}],"extension":null}


B: versions":[{"name":"operator","version":"4.5.0-0.nightly-2020-04-29-064431"},{"name":"csi-snapshot-controller","version":"4.5.0-0.nightly-2020-04-29-064431"}],"relatedObjects":[{"group":"","resource":"namespaces","name":"openshift-cluster-storage-operator"},{"group":"","resource":"namespaces","name":"openshift-cluster-storage-operator"},{"group":"operator.openshift.io","resource":"csisnapshotcontrollers","name":"cluster"}],"extension":null}


It's too long and it's hard to see what changed (it's the operator version).

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-29-064431

How reproducible:
always

Steps to Reproduce:
1. Install OCP cluster
2. oc -n -n openshift-cluster-storage-operator get event

Comment 3 Qin Ping 2020-05-09 02:36:16 UTC
Verified with:
# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-05-08-222601   True        False         30m     Cluster version is 4.5.0-0.nightly-2020-05-08-222601


34m         Normal    OperatorVersionChanged            deployment/csi-snapshot-controller-operator             clusteroperator/csi-snapshot-controller version "csi-snapshot-controller" changed from "" to "4.5.0-0.nightly-2020-05-08-222601"
34m         Normal    OperatorVersionChanged            deployment/csi-snapshot-controller-operator             clusteroperator/csi-snapshot-controller version "operator" changed from "" to "4.5.0-0.nightly-2020-05-08-222601"
34m         Normal    OperatorStatusChanged             deployment/csi-snapshot-controller-operator             Status for clusteroperator/csi-snapshot-controller changed: status.versions changed from [] to [{"csi-snapshot-controller" "4.5.0-0.nightly-2020-05-08-222601"} {"operator" "4.5.0-0.nightly-2020-05-08-222601"}]
34m         Normal    OperatorStatusChanged             deployment/csi-snapshot-controller-operator             Status for clusteroperator/csi-snapshot-controller changed: Progressing changed from Unknown to True ("Progressing: Waiting for Deployment to act on changes"),Available changed from Unknown to False ("Available: Waiting for Deployment to deploy csi-snapshot-controller pods"),Upgradeable changed from Unknown to True (""),status.versions changed from [] to [{"operator" "4.5.0-0.nightly-2020-05-08-222601"} {"csi-snapshot-controller" "4.5.0-0.nightly-2020-05-08-222601"}]

Comment 4 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.