Bug 182934 - ignoredisk directive missing
ignoredisk directive missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-02-24 10:49 EST by Axel Thimm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-25 06:53:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2006-02-24 10:49:12 EST
Description of problem:
Previous releases of anaconda supported ignoreing given block devices (this is
useful when for instance the device in question is labeld with gpt)

FC5t3 does not support this syntax anymore.
Comment 1 Chris Lumens 2006-02-24 13:05:54 EST
Please attach your kickstart file to this bug report.
Comment 2 Axel Thimm 2006-02-24 13:59:24 EST
Here it is. Some entries like @distarch@ and @host@ get replaced with the
system's parameters. I dropped a couple of entries like rootpw and %packages/%post.

install
url --url http://install.atrpms.net/distributions/@distarch@
#
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
#
keyboard us
#xconfig --driver "ati" --videoram 8128 --resolution 800x600 --depth 16
#monitor --hsync 31.5-37.9 --vsync 50-70
#skipx
mouse --device=genericwheelps/2
#
network --device eth0 --bootproto static --ip 160.45.32.250 --netmask
255.255.252.0 --gateway 160.45.32.1 --nameserver
160.45.35.138,160.45.35.139,160.45.35.141 --hostname @hostname@
#firewall --enabled --port=ssh:tcp --port=ssh:tcp
firewall --disabled
#selinux --enforcing
selinux --permissive
authconfig --enableshadow --enablemd5 --enablecache
timezone --utc Europe/Berlin
#
#bootloader --location=mbr --append="rhgb quiet"
#bootloader --location=mbr --append="console=tty0 console=ttyS0,115200n8"
bootloader --location=mbr
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --all --drives=sda
part /boot --fstype ext3 --size=100 --ondisk=sda
part pv.42 --size=0 --grow --ondisk=sda
volgroup system@host@ pv.42
logvol / --fstype ext3 --name=root --vgname=system@host@ --size=1024 --grow
logvol swap --fstype swap --name=swap --vgname=system@host@ --size=1000 --grow
--maxsize=2000
ignoredisk --drives=sdb,sdc,sdd,sde,sdf,sdg,sdh,sdi,sdj,sdk,sdl,sdm

Comment 3 Chris Lumens 2006-02-24 14:53:25 EST
Please try with rawhide tomorrow.  Should be fixed.
Comment 4 Axel Thimm 2006-02-24 18:31:49 EST
Thanks Chris!

Currently rawhide doesn't install for me, at least not via pxe. I get

> Running anaconda, the Fedora Core system installer - please wait...
> Could not find platform independent libraries <prefix>
> ...

That's a different bug, but I cannot do any rawhide anaconda testing due to it.
Maybe you could look into this as well?
Comment 5 Axel Thimm 2006-02-25 06:53:22 EST
Today's rawhide installs via pxe and the ignoredisk directive works, thanks!

Note You need to log in before you can comment on or make changes to this bug.