Bug 1829408 - Vsphere - Machine are missing state
Summary: Vsphere - Machine are missing state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Alexander Demicev
QA Contact: Milind Yadav
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 14:06 UTC by Alexander Demicev
Modified: 2020-07-13 17:33 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 578 0 None closed Bug 1829408: Reconcile machine power state annotation 2020-10-08 11:58:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:01 UTC

Description Alexander Demicev 2020-04-29 14:06:20 UTC
Description of problem:
vSphere machines don't have any state set

ademicev-OSX:machine-api-operator ademicev$ oc get machines -o wide
NAME                          PHASE     TYPE   REGION   ZONE   AGE     NODE                          PROVIDERID    STATE
ademicev-hf2t7-master-0       Running                          42h     ademicev-hf2t7-master-0       vsphere://...
ademicev-hf2t7-master-1       Running                          42h     ademicev-hf2t7-master-1       vsphere://...
ademicev-hf2t7-master-2       Running                          42h     ademicev-hf2t7-master-2       vsphere://...
ademicev-hf2t7-worker-c9gqw   Running                          3h43m   ademicev-hf2t7-worker-c9gqw   vsphere://...
ademicev-hf2t7-worker-m7kvn   Running                          3h43m   ademicev-hf2t7-worker-m7kvn   vsphere://...
ademicev-hf2t7-worker-qgzn7   Running                          3h43m   ademicev-hf2t7-worker-qgzn7   vsphere://...

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Milind Yadav 2020-05-14 04:53:27 UTC
Validated on :
[miyadav@miyadav bugvsphere]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-05-13-221558   True        False         7m1s    Cluster version is 4.5.0-0.nightly-2020-05-13-221558

Steps:
1.oc  get machines -o wide 
[miyadav@miyadav bugvsphere]$ oc get machines -o wide
NAME                            PHASE     TYPE   REGION   ZONE   AGE   NODE                            PROVIDERID                                       STATE
miyadav-14-r4vxw-master-0       Running                          33m   miyadav-14-r4vxw-master-0       vsphere://422be05b-5e7b-a6c9-f199-5447a9693d5b   poweredOn
miyadav-14-r4vxw-master-1       Running                          33m   miyadav-14-r4vxw-master-1       vsphere://422b74bf-54fb-5379-7d69-93238c30e550   poweredOn
miyadav-14-r4vxw-master-2       Running                          33m   miyadav-14-r4vxw-master-2       vsphere://422b5a25-3294-3136-ae6e-5a71c86221be   poweredOn
miyadav-14-r4vxw-worker-s844d   Running                          24m   miyadav-14-r4vxw-worker-s844d   vsphere://422bb29c-b41e-4bcf-7ace-1ee44d57ba9c   poweredOn
miyadav-14-r4vxw-worker-t8nx9   Running                          24m   miyadav-14-r4vxw-worker-t8nx9   vsphere://422b620c-48b0-889f-4a94-2aab7269f9e1   poweredOn

Power off the VM and check again
[miyadav@miyadav bugvsphere]$ oc get machines -o wide
NAME                            PHASE     TYPE   REGION   ZONE   AGE   NODE                            PROVIDERID                                       STATE
miyadav-14-r4vxw-master-0       Running                          34m   miyadav-14-r4vxw-master-0       vsphere://422be05b-5e7b-a6c9-f199-5447a9693d5b   poweredOn
miyadav-14-r4vxw-master-1       Running                          34m   miyadav-14-r4vxw-master-1       vsphere://422b74bf-54fb-5379-7d69-93238c30e550   poweredOn
miyadav-14-r4vxw-master-2       Running                          34m   miyadav-14-r4vxw-master-2       vsphere://422b5a25-3294-3136-ae6e-5a71c86221be   poweredOn
miyadav-14-r4vxw-worker-s844d   Running                          25m   miyadav-14-r4vxw-worker-s844d   vsphere://422bb29c-b41e-4bcf-7ace-1ee44d57ba9c   poweredOff
miyadav-14-r4vxw-worker-t8nx9   Running                          25m   miyadav-14-r4vxw-worker-t8nx9   vsphere://422b620c-48b0-889f-4a94-2aab7269f9e1   poweredOn

Actual & Expected :
State should reflect machine state 

Moving to VERIFIED

Comment 4 errata-xmlrpc 2020-07-13 17:32:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.