Bug 1829409 - Update vsphere machine api from alpha to beta
Summary: Update vsphere machine api from alpha to beta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Alexander Demicev
QA Contact: jima
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 14:07 UTC by Alexander Demicev
Modified: 2020-07-13 17:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3523 0 None closed Bug 1829409: Update vsphere machine api to beta 2021-01-20 09:28:06 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:14 UTC

Description Alexander Demicev 2020-04-29 14:07:57 UTC
Description of problem:

Update vsphere machine api from alpha to beta

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 4 jima 2020-05-19 08:15:51 UTC
@Alexander, 

I checked that apiVersion of machine and machineset on IPI cluster with 4.5.0-0.nightly-2020-05-17-220731 on vsphere.
$ oc get machineset wzheng-45-q4cj5-worker -n openshift-machine-api -o json | jq -r .apiVersion
machine.openshift.io/v1beta1
$ oc get machine wzheng-45-q4cj5-master-0 -n openshift-machine-api -o json | jq -r .apiVersion
machine.openshift.io/v1beta1

Both apiVersion are v1beta1, is it enough to verify this issue?

Comment 5 Alexander Demicev 2020-05-19 11:58:26 UTC
Hi, yes this is enough

Comment 6 errata-xmlrpc 2020-07-13 17:32:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.