Bug 182942 - System reboots in endless loop with /forcefsck and /fsckoptions "-D"
System reboots in endless loop with /forcefsck and /fsckoptions "-D"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-24 12:13 EST by Michael McLagan
Modified: 2014-03-16 22:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 14:16:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael McLagan 2006-02-24 12:13:05 EST
Description of problem:

system does not proceed past fsck phase of boot process, reboots endlessly

Version-Release number of selected component (if applicable):

initscripts-8.11.1-1
e2fsprogs-1.38-0.FC4.1

How reproducible:

Seems to be consistant across attempts

Steps to Reproduce:
1. touch /forcefsck
2. echo "-D" > /fsckoptions
3. shutdown -r now
  
Actual results:

System continuously reboots, forces a check of the root drive, reboots
automatically (*** REBOOT LINUX *** from e2fsck)

Expected results:

The system would check the drive once, reboot and continue boot process.

Additional info:

FWIW, I don't know how the '-D' got into /fsckoptions.  I'd never heard of or
seen that particular param before.  Since only I have root access to the machine
this happened on, I'm guessing I invoked something that put it there, or I did
it while sleepadmining :)

Other than modifying rc.sysinit to remount / with rw, remove the /fsck* files,
remount / ro (which is done already) and then reboot I don't see much of a
solution to this either.  I'm betting there's arguments against doing the above,
part of which may even be compelling, I'm just not aware of it.

In any case, if there was a priority field in bugzilla I'd set it to "low" (as
opposed to severity which I take to address a different aspect) since I don't
think this is likely to appear much (or at all, other than dumb luck), but
unless the guy at the helm has a clue, they could end up like that guy in the
infamous video -- bashing his keyboard into the monitor, etc.
Comment 1 Miloslav Trmač 2006-11-10 14:16:43 EST
Thanks for your report.

When fsck indicates the system should be rebooted, it is probably because it
isn't safe to remount it read-write at the moment;  therefore there is no way
to preserve the information that an automatic reboot has just been perfomed.

Note You need to log in before you can comment on or make changes to this bug.