Bug 18295 - Apache PHP startup error
Apache PHP startup error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 01:43 EDT by Todd Clark
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 18:58:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Clark 2000-10-04 01:43:13 EDT
I upgraded from 6.2 to 7 today and ran into a problem with Apache 1.13.12 
not being able to start-up on account of an error involving PHP4 module 
compiled as a DSO module using mysql. I tried recompiling it and 
re-installing a clean version of MySQL but no luck. This is NOT using the 
stock Redhat Apache module.

APACHE ERROR:
Cannot load /usr/local/apache/libexec/libphp4.so into server: libgd.so.1: 
cannot open shared object file: No such file or directory

My setup worked correctly with no problems unde
Comment 1 Ulrich Sibiller 2000-10-04 10:36:09 EDT
Same problem here. I had to install gd-1.2 ans 1.8 parallel to get it running...
Comment 2 Nalin Dahyabhai 2000-10-04 15:07:01 EDT
The libgd.so.1 module is in the gd-1.2.x packages.  Rebuilding the php module
will probably fix this, but you'll need to back out any patches that are added
to make it build against 1.2 (they are not compatible at the API level, so
source changes are required).  Otherwise, there's not much we can do to fix it,
since it's not the version we shipped out and we don't know exactly how it was
compiled.

Note You need to log in before you can comment on or make changes to this bug.