Bug 1829542 - Windows VM guest tools missing features in UI
Summary: Windows VM guest tools missing features in UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1803756
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 18:21 UTC by Matt
Modified: 2020-10-27 15:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:58:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
missing message (117.68 KB, image/png)
2020-05-06 10:38 UTC, Yaacov Zamir
no flags Details
unnececarry warning (102.20 KB, image/png)
2020-05-06 10:39 UTC, Yaacov Zamir
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5490 0 None closed Bug 1829542: Add mount guest agent tools to vm wizard 2020-10-26 14:08:27 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:58:56 UTC

Description Matt 2020-04-29 18:21:13 UTC
Description of problem:
When Selecting a Windows Operating System in the VM creation wizard there is no indication that Guess Tools have been added to the virtual hardware section. (see design here)
http://openshift.github.io/openshift-origin-design/designs/virtualization/4.3/create-vm/step-1-genaral/#operating-system-field

Also: When the Tools are added there is a message with the default interface:
sata
Not recommended bus type. Recommended type is scsi
It is not clear if sata is required and should be left as is or if they should investigate further and select scsi which is marked Recommended. 


How reproducible:

very

Steps to Reproduce:
1. Create VM with wizard
2. Select windows as OS
3. Navigate to Virtual Hardware

Comment 1 Yaacov Zamir 2020-05-06 10:38:30 UTC
Created attachment 1685652 [details]
missing message

Comment 2 Yaacov Zamir 2020-05-06 10:39:24 UTC
Created attachment 1685661 [details]
unnececarry warning

Comment 3 Yaacov Zamir 2020-05-06 10:46:09 UTC
Ref:
https://bugzilla.redhat.com/show_bug.cgi?id=1803756 - show warning on sata devices

see https://bugzilla.redhat.com/show_bug.cgi?id=1803756#c2 about sata comment.

Comment 4 Yaacov Zamir 2020-05-18 15:30:52 UTC
Note:
> Also: When the Tools are added there is a message with the default interface:
> sata
> Not recommended bus type. Recommended type is scsi
> It is not clear if sata is required and should be left as is or if they should investigate further and select scsi which is marked Recommended. 

This part of this BZ is duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=1803756

Comment 5 Yaacov Zamir 2020-05-27 07:14:12 UTC
The warning message part of this BZ is solved in https://bugzilla.redhat.com/show_bug.cgi?id=1803756

The part about choosing to mount or not mount the guest agent tools still missing, users can still choose to mount / not mount the guest tools in the advanced section.

Moving to 4.6 because IMHO the ability to choose mount/not mount in settings page is a feature request that we can move to next release.

@Nelly FYI

Comment 6 Nelly Credi 2020-06-01 15:24:10 UTC
Ack

Comment 7 Tomas Jelinek 2020-07-10 05:45:23 UTC
Since this is more a feature than a bug, it should be tracked in jira. Since the work has already started keeping it here for one more sprint. If it will not converge, I will close and move to jira to properly plan for a release.

Comment 10 Guohua Ouyang 2020-09-04 01:25:54 UTC
Verified on master, It has a checkbox in the wizard general step for mounting Windows guest tools and there is no warning message in storage step.

Comment 12 errata-xmlrpc 2020-10-27 15:58:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.