Bug 1829549 - Unable to drag down the cloud shell
Summary: Unable to drag down the cloud shell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 18:35 UTC by cvogt
Modified: 2020-07-13 17:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5224 0 None closed Bug 1829549: fix resizing issues with cloud shell terminal drawer 2020-06-24 01:29:10 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:14 UTC

Description cvogt 2020-04-29 18:35:54 UTC
Description of problem:
Resizing the cloud shell terminal drawer can stop working when the mouse gets over the terminal iframe.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-29-040854

How reproducible:


Steps to Reproduce:
1. Install https://github.com/che-incubator/che-workspace-operator to enable the cloud shell terminal.
2. Click the terminal button in the masthead.
3. Fill out the form to start the terminal.
4. Note that recently there are some issues with oauth and you will need to get the iframe URL and login separately.
5. Once the terminal is loaded drag the window up. Then start dragging quickly by moving the mouse directly over the terminal iframe

Actual results:
Once the mouse is over the terminal iframe, the drawer stops resizing.

Expected results:
Drawer should continue resizing while the mouse is over the terminal iframe. Resizing should always be smooth.

Comment 4 Gajanan More 2020-05-09 08:16:03 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-09-014245
Browser: Google Chrome Version 81.0.4044.129
Marking this as verfied

Comment 5 errata-xmlrpc 2020-07-13 17:32:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.