Bug 1829552 - create project option should be hidden from users without permission
Summary: create project option should be hidden from users without permission
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 18:50 UTC by cvogt
Modified: 2020-07-13 17:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
terminal restricted access (188.42 KB, image/png)
2020-05-04 09:32 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5199 0 None open Bug 1829552: cloudshell: hide create project option with rbac check 2020-06-24 01:29:12 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:14 UTC

Description cvogt 2020-04-29 18:50:01 UTC
Description of problem:
Users without access to create projects should not be given the option when opening the cloudshell terminal.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-29-040854

How reproducible:


Steps to Reproduce:
1. Install https://github.com/che-incubator/che-workspace-operator to enable the cloud shell terminal.
2. Create a user without ability to create projects.
3. Click the terminal button in the masthead
3. The terminal will open with a form.

Actual results:
Form contains a "create" project action. Upon choosing this option and attempting to create the project, an error is shown.

Expected results:
Users without permission to create projects should not be given the option to create a project.

Comment 4 Gajanan More 2020-05-04 09:32:57 UTC
Created attachment 1684742 [details]
terminal restricted access

Comment 5 Gajanan More 2020-05-04 09:35:02 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-05-03-172622
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared
Marking this as verified.

Comment 6 errata-xmlrpc 2020-07-13 17:32:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.