Bug 1829591 - Condition: ManagementStateDegraded is shown on a non-degraded operator
Summary: Condition: ManagementStateDegraded is shown on a non-degraded operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1828958
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-29 20:27 UTC by Samuel Padgett
Modified: 2020-06-22 12:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the operand list in the Installed Operators page could show a status from the custom resource `status.conditions` where the condition did not have `status: true`. The web console will now only show a status for a condition with `status: true`.
Clone Of: 1828958
Environment:
Last Closed: 2020-06-02 11:18:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5238 None closed Bug 1829591: Fix handling of Operand conditions 2020-06-18 14:24:43 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:19:09 UTC

Description Samuel Padgett 2020-04-29 20:27:13 UTC
+++ This bug was initially created as a clone of Bug #1828958 +++

Description of problem:
Console shows that an operator is degraded, while Degraded condition is "False".

An operator managed by OLM has these conditions on its CR:
status:
  conditions:
    - lastTransitionTime: '2020-04-28T16:24:47Z'
      status: 'False'
      type: ManagementStateDegraded
    - lastTransitionTime: '2020-04-28T16:24:51Z'
      status: 'False'
      type: Degraded
    - lastTransitionTime: '2020-04-28T16:25:03Z'
      reason: AsExpected
      status: 'False'
      type: Progressing
    - lastTransitionTime: '2020-04-28T16:24:51Z'
      status: 'True'
      type: PrereqsSatisfied
    - lastTransitionTime: '2020-04-28T16:24:51Z'
      status: 'True'
      type: Upgradeable
    - lastTransitionTime: '2020-04-28T16:25:03Z'
      status: 'True'
      type: Available

Not sure why "Degraded" was chosen to be shown. "Available" is the most interesting one (but how can we tell Console that?)

Version-Release number of selected component (if applicable):
Server Version: 4.5.0-0.nightly-2020-04-28-084038

How reproducible:
Always

Steps to Reproduce:
1. Install AWS EBS CSI driver operator and create a CR for it.
(but the operator is not available in OLM yet... use QA registry)

See attached screenshot.

Comment 4 shahan 2020-05-26 05:29:36 UTC
 I got ErrImagePull for aws-ebs-csi-driver-operator pod using above catalogsource:


Normal   Scheduled  33m                   default-scheduler                                        Successfully assigned openshift-aws-ebs-csi-driver-operator/aws-ebs-csi-driver-operator-7f4d98c6cf-wswfv to qe-has-4pkkb-w-c-nsjkr.c.openshift-qe.internal
  Normal   Pulling    31m (x4 over 33m)     kubelet, qe-has-4pkkb-w-c-nsjkr.c.openshift-qe.internal  Pulling image "quay.io/jsafrane/aws-ebs-csi-driver-operator:latest"
  Warning  Failed     31m (x4 over 33m)     kubelet, qe-has-4pkkb-w-c-nsjkr.c.openshift-qe.internal  Failed to pull image "quay.io/jsafrane/aws-ebs-csi-driver-operator:latest": rpc error: code = Unknown desc = Requesting bear token: invalid status code from registry 405 (Method Not Allowed)
  Warning  Failed     31m (x4 over 33m)     kubelet, qe-has-4pkkb-w-c-nsjkr.c.openshift-qe.internal  Error: ErrImagePull
  Warning  Failed     8m3s (x108 over 33m)  kubelet, qe-has-4pkkb-w-c-nsjkr.c.openshift-qe.internal  Error: ImagePullBackOff
  Normal   BackOff    3m6s (x130 over 33m)  kubelet, qe-has-4pkkb-w-c-nsjkr.c.openshift-qe.internal  Back-off pulling image "quay.io/jsafrane/aws-ebs-csi-driver-operator:latest"

@Jan, could you help have a look if the catalogsource is correct?

Comment 5 shahan 2020-05-28 03:57:28 UTC
try to install other operator which Degraded condition is "False", the status show Succeed
4.4.0-0.nightly-2020-05-27-032519

Comment 7 errata-xmlrpc 2020-06-02 11:18:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.