Bug 1829722 - Modal of create new project gets deactivated automatically
Summary: Modal of create new project gets deactivated automatically
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 07:45 UTC by Gajanan More
Modified: 2020-07-13 17:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Modal gets deactivated and it searches the operator name (1.65 MB, video/mp4)
2020-04-30 07:45 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5252 0 None closed Bug 1829722: Fix various search input focus bugs 2020-06-24 01:30:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:51 UTC

Description Gajanan More 2020-04-30 07:45:17 UTC
Created attachment 1683206 [details]
Modal gets deactivated and it searches the operator name

Description of problem:
The modal of creating new project on the operator hub page automatically deactivates. User keeps on typing and didn't know what is actually happening. Please check the updating URL in the address bar. 

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-04-30-002507

How reproducible:
Every time

Steps to Reproduce:
1. Go to Administrator perspective and then Operators
2. Click on the Operator Hub and while the page is loading, from the drop down menu of Projects, click on create new project and the modal of create new project will pop up and now try to enter the name of project.
3. You will observe that the modal deactivates and the it start searching the name of the operator.

Actual results:
The modal of create new project should not get deactivated. 

Expected results:
It should only enter the name of the project.

Additional info:
Build: 4.5.0-0.nightly-2020-04-30-002507
Browser: Google Chrome Version 81.0.4044.129

Please have a look at the attached video.

Comment 1 Samuel Padgett 2020-04-30 15:56:09 UTC
It looks like the OperatorHub search input is stealing focus from behind the modal.

Comment 2 Samuel Padgett 2020-04-30 16:08:39 UTC
The focus is set when the component is mounted here. This steals focus from the dialog.

https://github.com/spadgett/console/blob/3c517e3b8d6677e0f5e8ebc0a15a0cdd7886e3d6/frontend/public/components/utils/tile-view-page.jsx#L572

Comment 5 shahan 2020-05-06 07:01:09 UTC
create project works well in operatorhub page.
4.5.0-0.nightly-2020-05-04-113741

Comment 6 errata-xmlrpc 2020-07-13 17:32:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.