Bug 1829737 - Migrate operator controllers to library-go controller factory
Summary: Migrate operator controllers to library-go controller factory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 08:55 UTC by Michal Fojtik
Modified: 2020-07-13 17:33 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:32:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 324 0 None closed Bug 1829737: operator: migrate controllers to factory 2020-06-24 01:30:27 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:51 UTC

Description Michal Fojtik 2020-04-30 08:55:11 UTC
Description of problem:

Etcd operator controllers are hand written and not error prone.
Moving them to factory guarantee the graceful shutdown of each individual controller.
It also remove a lot of boiler plate code we use to make controllers as well as making sure all informers have event handlers registered and we properly wait for every informer cache sync.


Version-Release number of selected component (if applicable):


How reproducible:

This is refactoring/stabilization and there is nothing to reproduce.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

QE: After the https://github.com/openshift/cluster-etcd-operator/pull/324 land, we can verify this BZ just by running standard regression suite against etcd operator (all tests) to make sure nothing regressed, there is no new test needed.

Comment 3 ge liu 2020-05-26 10:06:07 UTC
Verified with 4.5.0-0.nightly-2020-05-25-012559, run some regression and passed without err.

Comment 4 errata-xmlrpc 2020-07-13 17:32:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.