Bug 1829761 - Rebase OpenSCAP in RHEL 8.3 to the latest upstream version
Summary: Rebase OpenSCAP in RHEL 8.3 to the latest upstream version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: openscap
Version: 8.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.3
Assignee: Jan Černý
QA Contact: Matus Marhefka
Mirek Jahoda
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 09:41 UTC by Evgeny Kolesnikov
Modified: 2020-11-04 02:30 UTC (History)
6 users (show)

Fixed In Version: openscap-1.3.3-1.el8
Doc Type: Enhancement
Doc Text:
.*OpenSCAP* rebased to version 1.3.3 The `openscap` packages have been upgraded to upstream version 1.3.3, which provides many bug fixes and enhancements over the previous version, most notably: * Added the `autotailor` script that enables you to generate tailoring files using a command-line interface (CLI). * Added the timezone part to the Extensible Configuration Checklist Description Format (XCCDF) TestResult start and end time stamps * Added the `yamlfilecontent` independent probe as a draft implementation. * Introduced the `urn:xccdf:fix:script:kubernetes` fix type in XCCDF. * Added ability to generate the `machineconfig` fix. * The `oscap-podman` tool can now detect ambiguous scan targets. * The `rpmverifyfile` probe can now verify files from the `/bin` directory. * Fixed crashes when complicated regexes are executed in the `textfilecontent58` probe. * Evaluation characteristics of the XCCDF report are now consistent with OVAL entities from the `system_info` probe. * Fixed file-path pattern matching in offline mode in the `textfilecontent58` probe. * Fixed infinite recursion in the `systemdunitdependency` probe.
Clone Of:
Environment:
Last Closed: 2020-11-04 02:29:43 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4623 0 None None None 2020-11-04 02:29:57 UTC

Description Evgeny Kolesnikov 2020-04-30 09:41:37 UTC
Description of problem:

Latest upstream version of OpenSCAP fixes bugs reported in RHEL and provides new features requested by customers and community. It also fixes a large amount of issues reported upstream. The API/ABI is fully compatible with previous release shipped in RHEL 8.2.

Notable changes are: Support for yamlfilecontent OVAL check, hybrid offline mode for OVAL probes, script for CLI tailoring (autotailor), support for 'kubernetes' remediations.

Version-Release number of selected component (if applicable):
-

How reproducible:
always

Steps to Reproduce:
1. rpm -q openscap

Actual results:
Outdated version of OpenSCAP.


Expected results:
Latest upstream version of OpenSCAP.

Comment 1 Evgeny Kolesnikov 2020-04-30 09:42:44 UTC
A new version has been released in upstream:
https://github.com/OpenSCAP/openscap/releases/tag/1.3.3

Comment 16 errata-xmlrpc 2020-11-04 02:29:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (openscap bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4623


Note You need to log in before you can comment on or make changes to this bug.