Bug 1829788 - vm detail of topology view does not take migrating/importing statuses into account
Summary: vm detail of topology view does not take migrating/importing statuses into ac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 11:26 UTC by Filip Krepinsky
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:33:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5242 0 None closed Bug 1829788: take migrating/importing statuses into account in VM topology view 2020-06-24 01:30:49 UTC
Github openshift console pull 5551 0 None open Bug 1829788: pass resources pods to vm status 2020-06-24 01:30:49 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:59 UTC

Description Filip Krepinsky 2020-04-30 11:26:07 UTC
Description of problem:
vm detail of topology view does not take migrating/importing statuses into account and shows wrong actions and wrong statuses



How reproducible:
100

Steps to Reproduce:
1. Create VM with CDI import
2. CDI import status is not shown in topology view. And actions allow it to start

Comment 4 Filip Krepinsky 2020-05-25 14:21:22 UTC
The pods were not passed correctly so CDI importing status was computed incorrectly. Posted 2nd PR to fix this issue.

Comment 7 Radim Hrazdil 2020-05-26 06:52:49 UTC
Verified that VM statuses work as expected on the Topology page

Comment 8 errata-xmlrpc 2020-07-13 17:33:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.