Bug 1829791 - topology view does not listen on VM resources changes and shows wrong status and set of actions
Summary: topology view does not listen on VM resources changes and shows wrong status ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Ido Rosenzwig
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 11:42 UTC by Filip Krepinsky
Modified: 2020-07-13 17:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:33:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5470 0 None closed bug 1829791: Fix VM status and action dropdown in topology view 2020-08-26 05:39:06 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:59 UTC

Description Filip Krepinsky 2020-04-30 11:42:26 UTC
How reproducible:
100


Steps to Reproduce:
1. navigate to VM topology detail
2. status shows off
3. click start and do not refresh the page or the detail view (close + show)
4. status shows off


Expected results:
in 4. status shows Starting and Running afterwards

Comment 3 Guohua Ouyang 2020-05-27 08:21:26 UTC
verified on upstream 4.5 branch, commit 88b7689b0fb3dfc557d9e06dc509952b9233661e.
it shows Off -> Starting -> Running without refresh detail page.

Comment 4 errata-xmlrpc 2020-07-13 17:33:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.