Bug 1829869 - Data entered in YAML editor can be lost when switching to Form editor
Summary: Data entered in YAML editor can be lost when switching to Form editor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1827538
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 13:54 UTC by Peter Kreuser
Modified: 2020-07-13 17:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Manifested, discovered, and fixed before release.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:33:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Short term UX design (309.34 KB, image/png)
2020-04-30 13:54 UTC, Peter Kreuser
no flags Details
Verification screenshot (211.85 KB, image/png)
2020-05-15 06:54 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5361 0 None closed Bug 1829869: Add confirmation step when toggling from yaml to form during operand creation 2020-07-02 20:11:04 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:59 UTC

Description Peter Kreuser 2020-04-30 13:54:46 UTC
Created attachment 1683317 [details]
Short term UX design

Description of problem:
When using the new form/YAML switching interaction (new for 4.4/4.5) for creating and editing operator custom resources, the user can enter incorrectly formed YAML in the YAML editor and is not notified that upon switching to the form editor, this data is lost. Ideally we'd highlight in the editor that the YAML is malformed, but we should at least warn the user on switching to the form editor that this malformed YAML will be lost (ideally with the line number of the malformed YAML if possible.)

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1.Create a new operator custom resource (operand) and enter malformed YAML in the YAML editor
2.Switch to the form editor
3.Switch back to the YAML editor.

Actual results:
The malformed YAML is no longer present upon switching back to the YAML editor.

Expected results:
The user should have been warned when switching away from the YAML editor initially that the malformed YAML will be lost, so they can review the YAML or be aware of its removal.

Additional info:
Discussed solution with Ben P and Jon J, maybe we just do attached design for now with intent to enhance in 4.6.

Comment 1 Jon Jackson 2020-05-07 19:13:10 UTC
There is a fix pending for this, but the PR can't be opened until https://github.com/openshift/console/pull/5237 merges

Comment 4 XiaochuanWang 2020-05-15 06:54:37 UTC
Created attachment 1688795 [details]
Verification screenshot

Comment 5 XiaochuanWang 2020-05-15 06:55:40 UTC
Latest version is as the design now. (refer to the the screenshot from attachment)
Verified on 4.5.0-0.nightly-2020-05-15-011814

Comment 6 errata-xmlrpc 2020-07-13 17:33:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.