Bug 1830010 - Event streaming grid is inaccessible on events page
Summary: Event streaming grid is inaccessible on events page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jessie
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-30 17:27 UTC by Jessie
Modified: 2020-07-13 17:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:33:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Events Page error (255.80 KB, image/png)
2020-04-30 17:27 UTC, Jessie
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5299 0 None open Bug 1830010: Event streaming grid is inaccessible on events page 2020-06-24 01:32:14 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:33:59 UTC

Description Jessie 2020-04-30 17:27:22 UTC
Created attachment 1683388 [details]
Events Page error

Description of problem:
When on the events page, the events stream grid isn't accessible by screen reader (particularly tested with Voice Over). It is read as "grid 0 columns 8 rows" and the user is unable to get into the grid. This error was noticed through axe testing, the error looks as follows: 
 {
    "data": [
      "cell",
      "columnheader",
      "rowheader",
      "gridcell"
    ],
    "id": "aria-required-children",
    "impact": "critical",
    "message": "Required ARIA children role not present: cell columnheader rowheader gridcell",
    "relatedNodes": [
      {
        "html": "<div class="co-sysevent--transition" role="row" style="height: 171px; left: 0px; position: absolute; top: 279px; width: 100%;">"
      }
    ]
  }

This seems to affect the following pages: 
http://localhost:9000/k8s/ns/default/events
http://localhost:9000/k8s/ns/openshift-machine-api/events
http://localhost:9000/k8s/ns/a-serverless-example/events
http://localhost:9000/k8s/ns/knative-serving/events
http://localhost:9000/k8s/ns/knative-serving-ingress/events
http://localhost:9000/k8s/ns/kube-system/events
http://localhost:9000/k8s/ns/openshift-authentication/events
http://localhost:9000/k8s/ns/openshift-cluster-node-tuning-operator/events


Version-Release number of selected component (if applicable):


How reproducible:
You can see this error by using the Axe Chrome Extension. 

Steps to Reproduce:
1. Inspect the page,
2. Click on the axe tab
3. Click "Analyze" - this issue is the one that says, "Certain ARIA roles must contain particular children"

Alternatively, you can open up VO by pressing command and F5, press control, option, and U to open the rotor, use the arrow left and right keys to get to the table menu, find the grid, then try to navigate into the grid (you can get into an item by pressing control, option, shift, and down arrow then navigate by control, option, right and left arrow).

Actual results:
An events stream grid that is inaccessible by screen reader.

Expected results:
To be able to navigate and understand the events stream grid through screen reader.


Additional info:

Comment 4 errata-xmlrpc 2020-07-13 17:33:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.