Bug 183014 - jpilot crashes (invalid pointer)
jpilot crashes (invalid pointer)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
: 183259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 05:13 EST by Ralph Angenendt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 08:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Angenendt 2006-02-25 05:13:19 EST
Description of problem:

When trying to start jpilot it directly crashes with 

[ralph@logout ~]$ jpilot
removing stale pidfile
GTK Accessibility Module initialized
/home/ralph/.themes/Ana/gtk-2.0/../icons/iconrc:13: Unable to locate image file
in pixmap_path: "gnome-stock-edit.png"
*** glibc detected *** jpilot: free(): invalid pointer: 0x09412cf0 ***
======= Backtrace: =========
/lib/libc.so.6[0x164de8]
/lib/libc.so.6(__libc_free+0x79)[0x1682ed]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0x394581]
jpilot[0x807e0a4]
jpilot(get_main_menu+0x37d)[0x807e45d]
jpilot(main+0xbb7)[0x80812c7]
/lib/libc.so.6(__libc_start_main+0xdc)[0x1167a4]
jpilot[0x8053bf1]
======= Memory map: ========
[...]


Version-Release number of selected component (if applicable):

jpilot-0.99.8-2.2.1


How reproducible:

Always.

Steps to Reproduce:
1. Start jpilot
  
Actual results:

jpilot crashes.

Expected results:

jpilot should run.

Additional info:

SELinux is turned off at the moment
Comment 1 Ralph Angenendt 2006-02-26 06:52:34 EST
This is the backtrace I get when running jpilot in gdb:

(gdb) bt
#0  0x0024d402 in __kernel_vsyscall ()
#1  0x001290f9 in raise () from /lib/libc.so.6
#2  0x0012a683 in abort () from /lib/libc.so.6
#3  0x0015d8db in __libc_message () from /lib/libc.so.6
#4  0x00164de8 in _int_free () from /lib/libc.so.6
#5  0x001682ed in free () from /lib/libc.so.6
#6  0x003944d1 in g_free () from /usr/lib/libglib-2.0.so.0
#7  0x0807e0a4 in get_inline_pixbuf_data.38241 () at jpilot.c:1374
#8  0x0807e45d in get_main_menu (window=0x9fc4028, menubar=0xbf948e8c,
    plugin_list=0x9fa0100) at jpilot.c:1441
#9  0x080812c7 in main (argc=0, argv=0xbf9498f4) at jpilot.c:2442
(gdb)

Maybe that helps a little bit further.

Regards, 

Ralph
Comment 2 Ivana Varekova 2006-02-27 08:26:18 EST
Thank you for your bug report. 
This problem is fixed in jpilot-0.99.8-3. If there is any problem please reopen
this bug.
Comment 3 Ivana Varekova 2006-02-28 02:54:38 EST
*** Bug 183259 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.