Bug 183017 - memory usage always grows during large file operations
memory usage always grows during large file operations
Status: CLOSED DUPLICATE of bug 182970
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 06:43 EST by Matteo Brancaleoni
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 02:21:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump of cat /proc/slabinfo (4.29 KB, application/x-gzip)
2006-02-25 06:43 EST, Matteo Brancaleoni
no flags Details

  None (edit)
Description Matteo Brancaleoni 2006-02-25 06:43:14 EST
Description of problem:
During large file operations (actualy copying files via network from the
old machine to the newer), the memory usage of the system increases,
up to filling the whole swap and thus the system is unusable.
killing the transfer does nothing, the memory never get freed.
Happens of any type of network transfer, scp, rsync, ftp

Version-Release number of selected component (if applicable):
Linux morgor 2.6.15-1.1977_FC5 #1 SMP Thu Feb 23 14:55:24 EST 2006 x86_64 x86_64
x86_64 GNU/Linux

How reproducible:
always

Steps to Reproduce:
1. do a transfer of many, large files via network. use any method. verified
with scp, rsync -e ssh, ftp. Actualy was copying from network
something like 30gb of large files to the FC5-test3 machine.
  
Actual results:
the memory usage increase, when full the cache mem decrease and then
swap is used... when also swap is full, the system is unusable.
Killing the process that does the transfer does nothing, the memory
never get freed.


Additional info:
seems something into the kernel, looking at /proc/slabinfo bio and biovec-1
grow in obj number. attached slabinfo dump.

* /proc/cpuinfo:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 47
model name      : AMD Athlon(tm) 64 Processor 3200+
stepping        : 0
cpu MHz         : 1000.000
cache size      : 512 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow
pni lahf_lm
bogomips        : 2007.50
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm st

* mount
/dev/md1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/md0 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
192.168.1.63:/home on /home type nfs (rw,addr=192.168.1.63)
192.168.1.63:/mnt/bigdisk/space on /mnt/space type nfs (rw,addr=192.168.1.63)
automount(pid2028) on /net type autofs (rw,fd=4,pgrp=2028,minproto=2,maxproto=4)

* lsmod
Module                  Size  Used by
ipv6                  399201  18
ppdev                  42569  0
autofs4                55369  1
nfs                   251417  2
lockd                  97105  2 nfs
nfs_acl                36929  1 nfs
sunrpc                192265  4 nfs,lockd,nfs_acl
rfcomm                105057  0
l2cap                  91841  5 rfcomm
bluetooth             117189  4 rfcomm,l2cap
dm_mirror              54721  0
dm_mod                 90385  1 dm_mirror
video                  50633  0
button                 40673  0
battery                43465  0
ac                     38601  0
lp                     47761  0
parport_pc             62825  1
parport                74189  3 ppdev,lp,parport_pc
nvram                  42569  0
sg                     69225  0
ehci_hcd               65357  0
snd_via82xx            63465  0
gameport               50513  1 snd_via82xx
snd_ac97_codec        136217  1 snd_via82xx
nvidia               4892976  0
snd_ac97_bus           35905  1 snd_ac97_codec
ohci1394               68121  0
uhci_hcd               65633  0
ieee1394              392025  1 ohci1394
snd_seq_dummy          37189  0
snd_seq_oss            66369  0
snd_seq_midi_event     41281  1 snd_seq_oss
snd_seq                89953  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            85713  0
snd_mixer_oss          51009  1 snd_pcm_oss
snd_pcm               126537  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer              59593  2 snd_seq,snd_pcm
snd_page_alloc         44625  2 snd_via82xx,snd_pcm
snd_mpu401_uart        41793  1 snd_via82xx
snd_rawmidi            61505  1 snd_mpu401_uart
i2c_viapro             42841  0
i2c_core               57537  1 i2c_viapro
snd_seq_device         42961  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
skge                   72273  0
snd                    97257  11
snd_via82xx,snd_ac97_codec,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              44257  1 snd
raid1                  54977  2
ext3                  164177  2
jbd                    93672  1 ext3
sata_promise           45893  6
sata_via               42565  0
libata                 93913  2 sata_promise,sata_via
sd_mod                 50881  8
scsi_mod              181393  4 sg,sata_promise,libata,sd_mod
Comment 1 Matteo Brancaleoni 2006-02-25 06:43:14 EST
Created attachment 125240 [details]
dump of cat /proc/slabinfo
Comment 2 Dave Jones 2006-02-27 02:21:33 EST

*** This bug has been marked as a duplicate of 182970 ***

Note You need to log in before you can comment on or make changes to this bug.