Bug 1830181 - consoledev Doesn't See Disabled Pipeline Run Trigger LastRun Button
Summary: consoledev Doesn't See Disabled Pipeline Run Trigger LastRun Button
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-01 02:19 UTC by Vikram Raj
Modified: 2020-07-13 17:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
Before start (59.61 KB, image/png)
2020-05-21 10:32 UTC, spathak@redhat.com
no flags Details
After Start (74.54 KB, image/png)
2020-05-21 10:37 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5258 0 None closed Bug 1830181: Hide 'Start Last Run' button on topology overview page when no PLR present 2020-06-24 01:33:04 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:22 UTC

Description Vikram Raj 2020-05-01 02:19:15 UTC
Description of problem:
Description of problem:
When viewing the Pipeline Runs in the overview sidebar of topology, the consoledeveloper doesn't see the button when there are no pipeline runs, but does as soon as there are.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
On Admin:
1. Create a new namespace `foo`
2. Go through the +Add "From Git" flow and add a Pipeline (url isn't really important I don't think, but I used https://github.com/nodeshift-starters/nodejs-rest-http)

On 'consoledeveloper':

1. Go to the `foo` namespace
2. Go to the topology page
3. Click on the new node and look at the sidebar

Back on Admin:

1. Start the Pipeline
Actual results:
For Admin Start Pipeline button is disabled when no pipeline run is present. and hidden for the developer.

Expected results:
Should have the same visible result on both sides with the same permission

Additional info:

Comment 3 spathak@redhat.com 2020-05-21 10:32:20 UTC
Created attachment 1690584 [details]
Before start

Comment 4 spathak@redhat.com 2020-05-21 10:37:07 UTC
Created attachment 1690585 [details]
After Start

Comment 5 spathak@redhat.com 2020-05-21 10:37:42 UTC
Verified on build version: 4.5.0-0.nightly-2020-05-20-221742
Verified on browser version: Firefox 73

Comment 6 errata-xmlrpc 2020-07-13 17:34:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.