Bug 18302 - Bad cdrom device names in installation
Bad cdrom device names in installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
: 30509 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 03:35 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 14:52:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-04 03:35:46 EDT
During installation or upgrade if more than 10 scsi cdrom are found the
devices beyond 9 have incorrect names.
"0","1","2","3","4","5","6","7","8","9",":",";","<","=", etc....
scd0,....,"scd:","scd;",scd<","scd=",etc...
also the names in mnt are wrong.

Obviously this error is cause by the fact that numbers are assigned adding
0x30 hex value to the device number (ascii 0) and not checking for values
greater than 9.
Comment 1 Michael Fulbright 2000-10-04 18:26:12 EDT
Could you please try 7.0 out and let us know if it works better?

Comment 2 Need Real Name 2000-10-05 03:48:49 EDT
Unfortunately my multiple cd machine is going into production environment and I
have not hardrive space to make another installation.
Upgrading to 7.0 is not planned now (unfortunately too many bugs in my
testings).
Comment 3 Alan Cox 2000-10-15 20:04:35 EDT
*** Bug 19132 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2000-11-07 14:50:35 EST
What would be the correct names and major,minor numbers for the drives beyond
the 10th?
Comment 5 Need Real Name 2000-11-07 16:39:34 EST
I have major always 11 and minor ranging from 0 to 20 and they are actually all
working!
brw-rw----    1 root     disk      11,   0 May  5  1998 /dev/scd0
brw-rw----    1 root     disk      11,   1 May  5  1998 /dev/scd1
brw-r-----    1 root     root      11,  10 Dec 10  2000 /dev/scd10
brw-r-----    1 root     root      11,  11 Dec 10  2000 /dev/scd11
brw-r-----    1 root     root      11,  12 Dec 10  2000 /dev/scd12
brw-r-----    1 root     root      11,  13 Dec 10  2000 /dev/scd13
brw-r-----    1 root     root      11,  14 Dec 10  2000 /dev/scd14
brw-r-----    1 root     root      11,  15 Dec 10  2000 /dev/scd15
brw-r-----    1 root     root      11,  16 Dec 10  2000 /dev/scd16
brw-r-----    1 root     root      11,  17 Dec 10  2000 /dev/scd17
brw-r-----    1 root     root      11,  18 Dec 10  2000 /dev/scd18
brw-r-----    1 root     root      11,  19 Dec 10  2000 /dev/scd19
brw-rw----    1 root     disk      11,   2 May  5  1998 /dev/scd2
brw-r-----    1 root     root      11,  20 Dec 10  2000 /dev/scd20
brw-rw----    1 root     disk      11,   3 May  5  1998 /dev/scd3
brw-rw----    1 root     disk      11,   4 May  5  1998 /dev/scd4
brw-rw----    1 root     disk      11,   5 May  5  1998 /dev/scd5
brw-rw----    1 root     disk      11,   6 May  5  1998 /dev/scd6
brw-rw----    1 root     disk      11,   7 May  5  1998 /dev/scd7
brw-r-----    1 root     root      11,   8 Dec 10  2000 /dev/scd8
brw-r-----    1 root     root      11,   9 Dec 10  2000 /dev/scd9

I think you may hit a limit on 63 ??
Comment 6 Michael Fulbright 2000-11-15 12:25:54 EST
Thanks for the feedback, assigning to an engineer.
Comment 7 Erik Troan 2000-11-20 10:56:20 EST
Fixed in kudzu in CVS -- thanks for the report.
Comment 8 Brock Organ 2000-12-11 16:14:22 EST
unable to verify w/internal test lab equipment, please reopen if still a
problem!
Comment 9 Michael Fulbright 2001-03-04 00:14:35 EST
*** Bug 30509 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.