Bug 1830259 - Helm and Operator backed items in topology should not provide 'Edit Application Grouping'
Summary: Helm and Operator backed items in topology should not provide 'Edit Applicati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-01 11:31 UTC by Jeff Phillips
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
operator backed (190.01 KB, image/png)
2020-05-15 05:48 UTC, Gajanan More
no flags Details
helm chart (253.03 KB, image/png)
2020-05-15 05:48 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5259 0 None closed Bug 1830259: Do not allow regrouping of helm charts or OBS groupings 2020-06-24 01:33:05 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:22 UTC

Description Jeff Phillips 2020-05-01 11:31:33 UTC
Description of problem:

Helm releases and operator backed services should not be allowed to be regrouped.

Remove the `edit application` action menu and disable the drag to regroup operation.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

1. install a helm chart and operator backed service
2. navigate to topology
3. right click a helm release, an operator backed services, or a workload within either, and observe the `Edit Application Grouping` action menu
4. Now attempt shift + drag of the same nodes to regroup into an existing group

Actual results:

The action menu shows `Edit Application Grouping`
Shift-drag shows the regrouping is available, dropping in a group regroups the item

Expected results:

The action menu does not show `Edit Application Grouping`
Shift-drag of the nodes does not regroup, it simply moves the nodes.

Additional info:

Comment 3 Gajanan More 2020-05-15 05:48:09 UTC
Created attachment 1688774 [details]
operator backed

Comment 4 Gajanan More 2020-05-15 05:48:28 UTC
Created attachment 1688775 [details]
helm chart

Comment 5 Gajanan More 2020-05-20 09:48:16 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.ci-2020-05-14-224329
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared
Marking this as verified.

Comment 6 errata-xmlrpc 2020-07-13 17:34:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.