Bug 1830270 - openshift-install lacks in binary install-config documentation
Summary: openshift-install lacks in binary install-config documentation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Abhinav Dahiya
QA Contact: Yunfei Jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-01 12:14 UTC by Scott Dodson
Modified: 2020-07-13 17:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Adds a subcommand to the installer binary `explain installconfig` that allows the users to see the fields available for install-config.yaml Users can use `explain installconfig[.subfield][.subfield]` to see documentation for subfields. The usage is very similar to `oc explain`
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3515 0 None closed Bug 1830270: cmd: add explain subcommand 2021-01-12 20:18:47 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:45 UTC

Description Scott Dodson 2020-05-01 12:14:49 UTC
install-config.yaml is a self documented api object but there's no accessible way to review the documentation for the API without going to github, it'd be nice if the installer provided a way to explain the API object and it were kept in sync with the specific version of the Installer I have downloaded as things change over time.

Comment 3 Mike Gahagan 2020-05-08 14:37:16 UTC
Confirmed openshift-install explain is working for installconfig, although we might want to clean up the example documentation a little since it references kubectl rather than openshift-install:

[m@localhost 45-azure-install]$ ./openshift-install explain -h
This command describes the fields associated with each supported InstallConfig API. Fields are identified via a simple
JSONPath identifier:

installconfig.<fieldName>[.<fieldName>]

Usage:
  openshift-install explain [flags]

Examples:

# Get the documentation of the resource and its fields
kubectl explain installconfig

# Get the documentation of a AWS platform
kubectl explain installconfig.platform.aws

Flags:
  -h, --help   help for explain

Global Flags:
      --dir string         assets directory (default ".")
      --log-level string   log level (e.g. "debug | info | warn | error") (default "info")

[m@localhost 45-azure-install]$ ./openshift-install explain installconfig
KIND:     InstallConfig
VERSION:  v1

RESOURCE: <object>
  InstallConfig is the configuration for an OpenShift install.

FIELDS:
    additionalTrustBundle <string>
      AdditionalTrustBundle is a PEM-encoded X.509 certificate bundle that will be added to the nodes' trusted certificate store.

    apiVersion <string>
      APIVersion defines the versioned schema of this representation of an object. Servers should convert recognized schemas to the latest internal value, and may reject unrecognized values. More info: https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources
<snip>

[m@localhost 45-azure-install]$ ./openshift-install explain installconfig.platform.azure
KIND:     InstallConfig
VERSION:  v1

RESOURCE: <object>
  Azure is the configuration used when installing on Azure.

FIELDS:
    baseDomainResourceGroupName <string>
      BaseDomainResourceGroupName specifies the resource group where the Azure DNS zone for the base domain is found.

    computeSubnet <string>
      ComputeSubnet specifies an existing subnet for use by compute nodes
<snip>

Verified with openshift-install-linux-4.5.0-0.nightly-2020-05-08-095803

Comment 4 Mike Gahagan 2020-05-08 16:17:49 UTC
Opened https://bugzilla.redhat.com/show_bug.cgi?id=1833425 for they help example referencing kubectl.

Comment 5 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.