Bug 1830298 - No network devices shows up when PXE booting via UEFI + IPv4
Summary: No network devices shows up when PXE booting via UEFI + IPv4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Julia Kreger
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On: 1830161
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-01 14:24 UTC by Stephen Benjamin
Modified: 2020-06-30 07:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1830161
Environment:
Last Closed: 2020-05-26 16:50:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
pxe_efi.png (18.61 KB, image/png)
2020-05-22 15:36 UTC, Marius Cornea
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift ironic-image pull 77 0 None closed Bug 1830298: Use snponly.efi instead of ipxe.efi for IPv4 2020-07-14 07:06:56 UTC
Red Hat Product Errata RHBA-2020:2180 0 None None None 2020-05-26 16:50:49 UTC

Description Stephen Benjamin 2020-05-01 14:24:27 UTC
+++ This bug was initially created as a clone of Bug #1830161 +++

Description of problem:

When booting via UEFI, using IPv4 PXE protocol, error of no network devices shows up. Via https://github.com/openshift/ironic-image/blob/master/dnsmasq.conf.j2#L28 we see that ipxe.efi is set but it should be using snponly.efi https://github.com/metal3-io/ironic-image/blob/master/dnsmasq.conf.j2#L41



Steps to Reproduce:
1. Ensure UEFI+ IPv4 PXE protocol in UEFI settings
2. Attempt an IPI on BM install

Actual results:
Fails to PXE masters with No network devices

Expected results:
Properly PXE the master nodes. 


https://github.com/openshift/ironic-image/blob/master/dnsmasq.conf.j2#L28
https://github.com/metal3-io/ironic-image/blob/master/dnsmasq.conf.j2#L41

--- Additional comment from Julia Kreger on 2020-05-01 00:13:14 UTC ---

UEFI stacks are supposed to supply network stacks to the firmware images loaded such as those for ipxe before the operating system loads. This means we should be using the snponly.efi binary for uefi with IPv4. With IPv6, the file is already correct.

Pull requests created for openshift and metal3.

https://github.com/openshift/ironic-image/pull/76
https://github.com/metal3-io/ironic-image/pull/152

Comment 5 Stephen Benjamin 2020-05-18 00:48:49 UTC
*** Bug 1835984 has been marked as a duplicate of this bug. ***

Comment 7 Marius Cornea 2020-05-22 15:36:30 UTC
Created attachment 1691126 [details]
pxe_efi.png

We can see that snponly.efi is loaded on IPv4 provisioning network with 4.4.5 image.

Comment 9 errata-xmlrpc 2020-05-26 16:50:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.