Bug 183035 - ekiga can't access webcam due to missing /dev/video0 authorization
ekiga can't access webcam due to missing /dev/video0 authorization
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 13:06 EST by Jukka Ketelaars
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 08:00:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jukka Ketelaars 2006-02-25 13:06:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060223 Fedora/1.5.0.1-5 Firefox/1.5.0.1

Description of problem:
Ekiga is unable to access a webcam at /dev/video0 due to the permission being 660 and group 'root'.

Version-Release number of selected component (if applicable):
udev-084-6

How reproducible:
Always

Steps to Reproduce:
1. connect webcam 
2. webcam shows up as /dev/video0
3. start ekiga
4. try to select webcam in first-run dialog or at Edit->Prefernces->Devices->Video devices
  

Actual Results:  Device does not show up.

Expected Results:  Device should have been selectable.

Additional info:

The problem is that /dev/video0 is created as root:root 660, so normal users can not access it. I fixed it by changing (in /etc/udev/rules.d/50-udev.rules) the video line from:
  KERNEL=="video*",               MODE="0660"
to:
  KERNEL=="video*",               MODE="0666"

This probably is not an ideal solution on anything other than a single user system.
Comment 1 Harald Hoyer 2006-02-27 08:00:52 EST
/etc/security/console.perms.d/50-default.perms should contain:
<v4l>=/dev/video* /dev/radio* /dev/winradio* /dev/vtx* /dev/vbi* \
      /dev/video/*

And as long, as you are a console user (first console login), you should own
this device.

Note You need to log in before you can comment on or make changes to this bug.