Bug 183037 - kernel-smp.i686 0:2.6.15-1.1977_FC5 hangs at boot.
kernel-smp.i686 0:2.6.15-1.1977_FC5 hangs at boot.
Status: CLOSED DUPLICATE of bug 182731
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 13:28 EST by David Bentley
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-26 18:19:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed re-install output (3.21 KB, text/plain)
2006-02-25 13:30 EST, David Bentley
no flags Details

  None (edit)
Description David Bentley 2006-02-25 13:28:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060223 Fedora/1.5.0.1-5 Firefox/1.5.0.1

Description of problem:
Kernel hangs at boot after detecting mouse.
kernel removed did todays (25/02/2006) updates and now 1977 fails to install.

I will add attacments as appropriate later.

Version-Release number of selected component (if applicable):
kernel-smp.i686 0:2.6.15-1.1977_FC5

How reproducible:
Always

Steps to Reproduce:
see description

Actual Results:  kernel 1977 now fails to install

Expected Results:  expected it to install again so that I could find out why it was hanging at boot.

Additional info:

attacments to follow
Comment 1 David Bentley 2006-02-25 13:30:05 EST
Created attachment 125255 [details]
failed re-install output

Text from failed re-install.
Comment 2 David Bentley 2006-02-25 13:55:52 EST
Looked for log of failed boot in messages but cant find any referaces for 1977
at boot is there anywhere else i could look.
Comment 3 David Fletcher 2006-02-26 07:26:33 EST
The final line of text that appears on the monitor is:-

input: ImPS/2 Generic Wheel Mouse as class/input/input1

/var/log/messages contains:-

#### Rebooted latest kernel
Feb 26 12:19:36 james gdm[2215]: Restarting computer...
Feb 26 12:19:36 james kernel: audit(:0): major=252 name_count=0: freeing
multiple contexts (1)
Feb 26 12:19:36 james kernel: audit(:0): major=113 name_count=0: freeing
multiple contexts (2)
Feb 26 12:19:37 james shutdown[2215]: shutting down for system reboot
Feb 26 12:19:37 james init: Switching to runlevel: 6
Feb 26 12:19:38 james gconfd (jf-2743): Received signal 15, shutting down cleanly
Feb 26 12:19:38 james gconfd (jf-2743): Exiting
Feb 26 12:19:40 james avahi-daemon[2088]: Got SIGTERM, quitting.
Feb 26 12:19:40 james avahi-daemon[2088]: Leaving mDNS multicast group on
interface eth0.IPv4 with address 192.168.2.100.
Feb 26 12:19:42 james ntpd[1914]: ntpd exiting on signal 15
Feb 26 12:19:42 james rpc.statd[1641]: Caught signal 15, un-registering and exiting.
Feb 26 12:19:42 james auditd[1585]: The audit daemon is exiting.
Feb 26 12:19:42 james kernel: audit(1140956382.987:43): audit_pid=0 old=1585 by
auid=4294967295
Feb 26 12:19:43 james kernel: Kernel logging (proc) stopped.
Feb 26 12:19:43 james kernel: Kernel log daemon terminating.
Feb 26 12:19:44 james exiting on signal 15
#### Pushed the reset button here
Feb 26 12:21:56 james syslogd 1.4.1: restart.
Feb 26 12:21:56 james kernel: klogd 1.4.1, log source = /proc/kmsg started.
Feb 26 12:21:56 james kernel: Linux version 2.6.15-1.1955_FC5smp
(bhcompile@hs20-bc1-4.build.redhat.com) (gcc version 4.1.0 20060214 (Red Hat
4.1.0-0.27))
 #1 SMP Wed Feb 15 16:01:54 EST 2006


Now it's working again with kernel 2.6.15-1.1955_FC5smp
Comment 4 David Fletcher 2006-02-26 07:38:14 EST
Forgot to add this before. The hardware is an Intel D865PERL motherboard with
3GHz P4 and a standard PS2 optical mouse. I think I installed a Seagate SATA
hard drive also. Device is /dev/sda1
Comment 5 Jef Spaleta 2006-02-26 08:53:51 EST
I'm having a similar experience with my old trusty athlon 1800mp smp system
using the 1975 and 1977 smp kernels.
Normally tne next message would be about LVM detection

Last messuage on boot concerns the ImPS/2 mouse
kernels that will not boot:
kernel-smp-2.6.15-1.1975_FC5
kernel-smp-2.6.15-1.1977_FC5

kernels that will boot:
kernel-smp-2.6.15-1.1939_FC5
kernel-smp-2.6.15-1.1948_FC5
kernel-smp-2.6.15-1.1955_FC5


I wonder is this related to a mkinitrd update perhaps and its just showing up as
a kernel problem?

-jef

Comment 6 Jef Spaleta 2006-02-26 12:22:04 EST
wierder and weirder...  kernel-2.6.15-1.1977_FC5   boots without issue whereas
the smp kernel fails to boot with the odd PS/2 mouse error so far reported.

I disconnect the mouse and try to boot kernel-smp-2.6.15-1.1977_FC5  and I get a
AT keyboard error at the same point in the boot scroll.

of course trying to boot without the keyboard makes my bios freakout so I can't
test that.

I've even downgraded to a mkinitrd that I know should work, and no difference.

So it appears to be an issue only with the smp kernels and its not just mouse
probing that has a problem.. mouseless systems result in a similar error with
the keyboard input.

I'm not sure how to get more information out of the scroll other than to attempt
to take a screenshot with my digital camera, which I really suck at doing.  

Please let me know what you'd like me to do to get more feedback from this system.

-jef
Comment 7 Dave Jones 2006-02-26 18:19:35 EST

*** This bug has been marked as a duplicate of 182731 ***

Note You need to log in before you can comment on or make changes to this bug.