RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1830397 - bluetooth unable to connect to bluetooth headphones
Summary: bluetooth unable to connect to bluetooth headphones
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: bluez
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: gopal krishna tiwari
QA Contact: Ken Benoit
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-01 20:04 UTC by Adam Miller
Modified: 2020-11-24 10:57 UTC (History)
10 users (show)

Fixed In Version: bluez-5.52-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 02:03:22 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4562 0 None None None 2020-11-04 02:03:24 UTC

Description Adam Miller 2020-05-01 20:04:55 UTC
Description of problem:
When I use GNOME Settings to try and connect a Bluetooth headset, it will connect, then immediate disconnect, and then never connect ever again.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. In GNOME: Activities -> Show Applications -> Settings
2. In Settings: Click on "Bluetooth", search for new device, find it, connect it.
3. Observe it immediately disconnect and have these logs in the journal:

Actual results:
May 01 14:59:31 latitude7390 systemd[1]: Starting Load/Save RF Kill Switch Status...
May 01 14:59:31 latitude7390 systemd[1]: Started Load/Save RF Kill Switch Status.
May 01 14:59:31 latitude7390 kernel: usb 1-7: new full-speed USB device number 62 using xhci_hcd
May 01 14:59:31 latitude7390 kernel: usb 1-7: New USB device found, idVendor=8087, idProduct=0a2b, bcdDevice= 0.10
May 01 14:59:31 latitude7390 kernel: usb 1-7: New USB device strings: Mfr=0, Product=0, SerialNumber=0
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: Bootloader revision 0.0 build 26 week 38 2015
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: Device revision is 16
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: Secure boot is enabled
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: OTP lock is enabled
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: API lock is enabled
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: Debug lock is disabled
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: Minimum firmware build 1 week 10 2014
May 01 14:59:31 latitude7390 kernel: Bluetooth: hci0: Found device firmware: intel/ibt-12-16.sfi
May 01 14:59:31 latitude7390 systemd[1]: Reached target Bluetooth.
May 01 14:59:31 latitude7390 upowerd[2315]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.1
May 01 14:59:31 latitude7390 upowerd[2315]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-7/1-7:1.0
May 01 14:59:31 latitude7390 upowerd[2315]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-7
May 01 14:59:33 latitude7390 kernel: Bluetooth: hci0: Waiting for firmware download to complete
May 01 14:59:33 latitude7390 kernel: Bluetooth: hci0: Firmware loaded in 1591612 usecs
May 01 14:59:33 latitude7390 kernel: Bluetooth: hci0: Waiting for device to boot
May 01 14:59:33 latitude7390 kernel: Bluetooth: hci0: Device booted in 11671 usecs
May 01 14:59:33 latitude7390 kernel: Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-12-16.ddc
May 01 14:59:33 latitude7390 kernel: Bluetooth: hci0: Applying Intel DDC parameters completed
May 01 14:59:38 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 01 14:59:44 latitude7390 xdg-desktop-por[11437]: Failed to get application states: GDBus.Error:org.freedesktop.portal.Error.Failed: Could not get window list: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: App introspection not allowed
May 01 14:59:55 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 01 15:00:11 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 01 15:00:11 latitude7390 bluetoothd[1299]: a2dp-sink profile connect failed for 20:9B:A5:83:87:64: Protocol not available
May 01 15:00:14 latitude7390 bluetoothd[1299]: a2dp-sink profile connect failed for 20:9B:A5:83:87:64: Protocol not available
May 01 15:00:16 latitude7390 bluetoothd[1299]: a2dp-sink profile connect failed for 20:9B:A5:83:87:64: Protocol not available

Comment 1 Steve Barcomb 2020-05-01 20:43:07 UTC
Hey Adam,
I just tried to reproduce this on my T480s running 8.2 and bluez-5.50-3 and I cannot reproduce this with a pair of Microsoft surface headphones.  Can you provide the following information:

1) Did this ever work for you in RHEL8?

2) What type of headset is failing?

3) Do you have the ability to test a second type of headset?

4) Can you attach an sosreport from the system having the issue?

-Steve

Comment 2 gopal krishna tiwari 2020-05-05 08:34:55 UTC
(In reply to Steve Barcomb from comment #1)
> Hey Adam,
> I just tried to reproduce this on my T480s running 8.2 and bluez-5.50-3 and
> I cannot reproduce this with a pair of Microsoft surface headphones.  Can
> you provide the following information:
> 
> 1) Did this ever work for you in RHEL8?
> 
> 2) What type of headset is failing?
> 
> 3) Do you have the ability to test a second type of headset?
> 
> 4) Can you attach an sosreport from the system having the issue?
> 
> -Steve

Along with what Steve has mentioned can you please check the pulseaudio package installed for bluetooth ? 

Following is the link to download the pulseaudio package for RHEL

https://brewweb.engineering.redhat.com/brew/packageinfo?packageID=12292

Gopal

Comment 3 Adam Miller 2020-05-20 03:04:05 UTC
(In reply to Steve Barcomb from comment #1)
> Hey Adam,
> I just tried to reproduce this on my T480s running 8.2 and bluez-5.50-3 and
> I cannot reproduce this with a pair of Microsoft surface headphones.  Can
> you provide the following information:
> 
> 1) Did this ever work for you in RHEL8?
> 

No, never. Works fine in Fedora 30, 31, and 32 though.

> 2) What type of headset is failing?

Anker SoundBuds Slim+
Anker PowerConf Bluetooth Speaker phone.

> 
> 3) Do you have the ability to test a second type of headset?
> 

I'll have to buy some, but yes.

> 4) Can you attach an sosreport from the system having the issue?

Attached
> 
> -Steve

Comment 5 Josh Boyer 2020-05-20 11:48:30 UTC
I have similar errors with some Jabra Active 75t and Bose QC35 headphones as well.

Comment 6 gopal krishna tiwari 2020-05-20 13:07:53 UTC
(In reply to Josh Boyer from comment #5)
> I have similar errors with some Jabra Active 75t and Bose QC35 headphones as
> well.

FC-30 is bluez-5.52 could see lot of changes related to audio codec's. Would it be possible to verify if I prepare a test bluez build with 5.52 or the latest one ? 

Gopal..

Comment 7 Josh Boyer 2020-05-20 15:59:54 UTC
(In reply to gopal krishna tiwari from comment #6)
> (In reply to Josh Boyer from comment #5)
> > I have similar errors with some Jabra Active 75t and Bose QC35 headphones as
> > well.
> 
> FC-30 is bluez-5.52 could see lot of changes related to audio codec's. Would
> it be possible to verify if I prepare a test bluez build with 5.52 or the
> latest one ? 
> 
> Gopal..

I'd be happy to test.

Comment 8 Adam Miller 2020-05-20 20:17:21 UTC
I've ordered a set of Skullcandy Ink'd+ Active bluetooth earbuds that will arrive on Friday, will update with my findings.

Comment 9 Adam Miller 2020-05-22 13:14:06 UTC
Confirmed, the new headphones also don't work:

May 22 07:58:38 latitude7390 systemd[1752]: Starting Bluetooth OBEX service...
May 22 07:58:39 latitude7390 obexd[33542]: OBEX daemon 5.50
May 22 07:58:39 latitude7390 dbus-daemon[1954]: [session uid=1000 pid=1954] Successfully activated service 'org.bluez.obex'
May 22 07:58:39 latitude7390 systemd[1752]: Started Bluetooth OBEX service.
May 22 07:58:39 latitude7390 kernel: Bluetooth: RFCOMM TTY layer initialized
May 22 07:58:39 latitude7390 kernel: Bluetooth: RFCOMM socket layer initialized
May 22 07:58:39 latitude7390 kernel: Bluetooth: RFCOMM ver 1.11
May 22 07:58:43 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available
May 22 07:58:44 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available
May 22 07:58:44 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available
May 22 07:58:45 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available
May 22 07:58:45 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available
May 22 07:58:46 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available
May 22 07:58:46 latitude7390 bluetoothd[1341]: a2dp-sink profile connect failed for 38:F3:2E:6A:AF:C0: Protocol not available

Comment 10 Adam Miller 2020-05-22 13:15:50 UTC
Sorry, forgot these in the above comment:

May 22 07:58:59 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 07:59:15 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 07:59:30 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 07:59:47 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 08:00:03 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 08:00:19 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 08:00:34 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 08:00:51 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
May 22 08:01:07 latitude7390 kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)

Comment 11 Adam Miller 2020-05-22 13:24:44 UTC
I tried this from bluetoothctl also, same behavior (and journal logs) I observed from using GNOME Settings:

$[bluetooth]# power on
Changing power on succeeded
$[bluetooth]# scan on
Discovery started
[CHG] Controller D0:C6:37:66:B5:74 Discovering: yes
[NEW] Device 61:6F:95:74:9E:B6 61-6F-95-74-9E-B6
[CHG] Device 38:F3:2E:6A:AF:C0 RSSI: -58
[CHG] Device 38:F3:2E:6A:AF:C0 TxPower: 4
[CHG] Device 38:F3:2E:6A:AF:C0 Class: 0x00240418
[CHG] Device 38:F3:2E:6A:AF:C0 Icon: audio-card
[CHG] Device 61:6F:95:74:9E:B6 RSSI: -93
[CHG] Device 61:6F:95:74:9E:B6 RSSI: -85
$[bluetooth]# pair 61:6F:95:74:9E:B6
Attempting to pair with 61:6F:95:74:9E:B6
[CHG] Device 61:6F:95:74:9E:B6 Connected: yes
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device 61:6F:95:74:9E:B6 Connected: no
[DEL] Device 61:6F:95:74:9E:B6 61-6F-95-74-9E-B6
[NEW] Device 61:6F:95:74:9E:B6 61-6F-95-74-9E-B6

Comment 12 Adam Miller 2020-05-22 14:57:31 UTC
Alright, so if I kill pulseaudio first and then do this from bluetoothcmd it does work and I'm able to play music through the headphones:

$ pulseaudio -k
$ bluetoothctl
$[bluetooth]# paired-devices
Device 38:F3:2E:6A:AF:C0 Ink'd+ Active
Device 20:9B:A5:83:87:64 SoundBuds Slim+
$[bluetooth]# connect 38:F3:2E:6A:AF:C0
Attempting to connect to 38:F3:2E:6A:AF:C0
[CHG] Device 38:F3:2E:6A:AF:C0 Connected: yes
Connection successful
[CHG] Device 38:F3:2E:6A:AF:C0 ServicesResolved: yes
$[Ink'd+ Active]# trust 38:F3:2E:6A:AF:C0
Changing 38:F3:2E:6A:AF:C0 trust succeeded

Comment 13 gopal krishna tiwari 2020-05-22 15:17:22 UTC
(In reply to Adam Miller from comment #12)
> Alright, so if I kill pulseaudio first and then do this from bluetoothcmd it
> does work and I'm able to play music through the headphones:
> 
> $ pulseaudio -k
> $ bluetoothctl
> $[bluetooth]# paired-devices
> Device 38:F3:2E:6A:AF:C0 Ink'd+ Active
> Device 20:9B:A5:83:87:64 SoundBuds Slim+
> $[bluetooth]# connect 38:F3:2E:6A:AF:C0
> Attempting to connect to 38:F3:2E:6A:AF:C0
> [CHG] Device 38:F3:2E:6A:AF:C0 Connected: yes
> Connection successful
> [CHG] Device 38:F3:2E:6A:AF:C0 ServicesResolved: yes
> $[Ink'd+ Active]# trust 38:F3:2E:6A:AF:C0
> Changing 38:F3:2E:6A:AF:C0 trust succeeded


Ok, Seems like we have some issue with pulseaudio. I'll try to check. 

Gopal..

Comment 14 gopal krishna tiwari 2020-05-22 15:20:19 UTC
(In reply to Josh Boyer from comment #7)
> (In reply to gopal krishna tiwari from comment #6)
> > (In reply to Josh Boyer from comment #5)
> > > I have similar errors with some Jabra Active 75t and Bose QC35 headphones as
> > > well.
> > 
> > FC-30 is bluez-5.52 could see lot of changes related to audio codec's. Would
> > it be possible to verify if I prepare a test bluez build with 5.52 or the
> > latest one ? 
> > 
> > Gopal..
> 
> I'd be happy to test.

Hi Josh, 

Can you please try and check with disabling pulseaudio and later tries to connect the device. Does this helps.

Gopal..

Comment 15 gopal krishna tiwari 2020-05-22 15:22:06 UTC
Hi Josh/Adam,

Here is the brew build with bluez - 5.52 

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=28758846

See if solves the issue. 

Gopal..

Comment 16 Adam Miller 2020-05-26 17:39:32 UTC
Gopal,
    It doesn't look like that build actually produced any RPMs

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=28758948
https://brewweb.engineering.redhat.com/brew/rpmlist?buildrootID=5995506&type=built

-AdamM

Comment 17 gopal krishna tiwari 2020-05-27 05:02:57 UTC
(In reply to Adam Miller from comment #16)
> Gopal,
>     It doesn't look like that build actually produced any RPMs
> 
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=28758948
> https://brewweb.engineering.redhat.com/brew/
> rpmlist?buildrootID=5995506&type=built
> 
> -AdamM

Seems its deleted due timeline .. Just fired another build. Please find below 

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=28854288

regards,
Gopal..

Comment 18 Josh Boyer 2020-06-01 12:16:55 UTC
Looked to be cleaned up again.  The retention period used to be longer for scratch builds.  My apologies for not grabbing it the day you rebuilt.  Can you do so one more time?

Comment 19 gopal krishna tiwari 2020-06-01 12:19:32 UTC
(In reply to Josh Boyer from comment #18)
> Looked to be cleaned up again.  The retention period used to be longer for
> scratch builds.  My apologies for not grabbing it the day you rebuilt.  Can
> you do so one more time?

Np's. Please check 

http://brew-task-repos.usersys.redhat.com/repos/scratch/gtiwari/bluez/5.52/4.el8/x86_64/

If you can download it from here else will fire the build again. 

Gopal..

Comment 20 Josh Boyer 2020-06-01 12:31:33 UTC
Yep, that works.  I'll test them this afternoon and also try killing pulseaudio as noted above.

Comment 21 gopal krishna tiwari 2020-06-01 12:37:42 UTC
(In reply to Josh Boyer from comment #20)
> Yep, that works.  I'll test them this afternoon and also try killing
> pulseaudio as noted above.

Sure.

Thanks 
Gopal..

Comment 22 Josh Boyer 2020-06-02 12:00:49 UTC
I was able to get the jabra headphones to pair, but they don't show up as having a mic in Gnome settings:

Jun 02 07:51:10 zod bluetoothd[1160]: /org/bluez/hci0/dev_70_BF_92_CA_B4_76/sep1/fd0: fd(25) ready
Jun 02 07:51:07 zod systemd-logind[1278]: Watching system buttons on /dev/input/event19 (70:BF:92:CA:B4:76)
Jun 02 07:51:07 zod kernel: input: 70:BF:92:CA:B4:76 as /devices/virtual/input/input20
Jun 02 07:51:03 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:51:03 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:51:03 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:51:01 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:51:00 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy

The Bose don't pair at all:

Jun 02 07:47:46 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:44 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:44 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:33 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:30 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:30 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:24 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:21 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:21 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:20 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:20 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:19 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:19 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:17 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:17 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:17 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:14 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:14 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:12 zod systemd[1524]: Started Mark boot as successful.
Jun 02 07:47:12 zod systemd[1524]: Starting Mark boot as successful...
Jun 02 07:47:12 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:09 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:09 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:09 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:09 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:08 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:08 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:47:06 zod bluetoothd[1160]: connect error: Device or resource busy (16)
Jun 02 07:47:06 zod bluetoothd[1160]: Unable to get Headset Voice gateway SDP record: Device or resource busy
Jun 02 07:46:32 zod systemd[1524]: Started Bluetooth OBEX service.

This is already better than before.  I haven't had a chance to try killing pulseaudio.

Comment 23 gopal krishna tiwari 2020-06-02 12:42:15 UTC
(In reply to Josh Boyer from comment #22)
> I was able to get the jabra headphones to pair, but they don't show up as
> having a mic in Gnome settings:
> 
> Jun 02 07:51:10 zod bluetoothd[1160]:
> /org/bluez/hci0/dev_70_BF_92_CA_B4_76/sep1/fd0: fd(25) ready
> Jun 02 07:51:07 zod systemd-logind[1278]: Watching system buttons on
> /dev/input/event19 (70:BF:92:CA:B4:76)
> Jun 02 07:51:07 zod kernel: input: 70:BF:92:CA:B4:76 as
> /devices/virtual/input/input20
> Jun 02 07:51:03 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:51:03 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:51:03 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:51:01 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:51:00 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> 
> The Bose don't pair at all:
> 
> Jun 02 07:47:46 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:44 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:44 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:33 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:30 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:30 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:24 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:21 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:21 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:20 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:20 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:19 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:19 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:17 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:17 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:17 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:14 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:14 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:12 zod systemd[1524]: Started Mark boot as successful.
> Jun 02 07:47:12 zod systemd[1524]: Starting Mark boot as successful...
> Jun 02 07:47:12 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:09 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:09 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:09 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:09 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:08 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:08 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:47:06 zod bluetoothd[1160]: connect error: Device or resource busy
> (16)
> Jun 02 07:47:06 zod bluetoothd[1160]: Unable to get Headset Voice gateway
> SDP record: Device or resource busy
> Jun 02 07:46:32 zod systemd[1524]: Started Bluetooth OBEX service.
> 
> This is already better than before.  I haven't had a chance to try killing
> pulseaudio.

Does bose headphone works with fc-30 ? Another do you see anything in dmesg output ? 

Gopal..

Comment 24 Josh Boyer 2020-06-02 12:56:16 UTC
(In reply to gopal krishna tiwari from comment #23)
> 
> Does bose headphone works with fc-30 ? Another do you see anything in dmesg
> output ? 

No idea.  I don't have a fedora machine handy.  There is nothing additional in dmesg.

I do remember long long ago when I first got those headphones that the firmware is very quirky and I only got it working on Fedora 20-something after a lot of fiddling.  I'm more than willing to ignore them and just focus on the jabra pair.  The jabra headphones work fine except for the mic not showing up, and I'll try messing with pulseaudio later.

Comment 25 gopal krishna tiwari 2020-06-02 12:59:41 UTC
(In reply to Josh Boyer from comment #24)
> (In reply to gopal krishna tiwari from comment #23)
> > 
> > Does bose headphone works with fc-30 ? Another do you see anything in dmesg
> > output ? 
> 
> No idea.  I don't have a fedora machine handy.  There is nothing additional
> in dmesg.
> 
> I do remember long long ago when I first got those headphones that the
> firmware is very quirky and I only got it working on Fedora 20-something
> after a lot of fiddling.  I'm more than willing to ignore them and just
> focus on the jabra pair.  The jabra headphones work fine except for the mic
> not showing up, and I'll try messing with pulseaudio later.

Sure, Thanks.

Regards,
Gopal

Comment 26 gopal krishna tiwari 2020-06-04 06:57:49 UTC
Hi Adam, 

I've checked the pulseaudio killing. If I understood it correctly it's basically to sync if in case its failing to pick up the device.  

Please let me know if you need anything else from my side. 

Gopal..

Comment 27 gopal krishna tiwari 2020-06-08 06:25:02 UTC
(In reply to gopal krishna tiwari from comment #26)
> Hi Adam, 
> 
> I've checked the pulseaudio killing. If I understood it correctly it's
> basically to sync if in case its failing to pick up the device.  
> 
> Please let me know if you need anything else from my side. 
> 
> Gopal..

Closing this out for now. Please feel free to re-open. 

Thanks Josh/Adam for your help on this. 

Gopal..

Comment 28 Josh Boyer 2020-06-08 12:58:17 UTC
Wait... why is this closed?  I only had success using the bluez scratch build you provided.  Is that change going to land in RHEL via some other bug?

Comment 29 gopal krishna tiwari 2020-06-08 13:20:26 UTC
(In reply to Josh Boyer from comment #28)
> Wait... why is this closed?  I only had success using the bluez scratch
> build you provided.  Is that change going to land in RHEL via some other bug?

Aaah my fault .. I took it completely wrongly :( .. My apologies. I'll import the changes soon. 

Gopal..

Comment 33 John Westerdale 2020-07-24 22:11:32 UTC
Saw this on RHEL 8.2 desktop. Seemed to be competing with itself over LE-Bose (low energy BT).

[CHG] Device 4C:87:5D:9D:42:AF Name: Bose NC 700 HP
[CHG] Device 4C:87:5D:9D:42:AF Alias: Bose NC 700 HP
[CHG] Device 4C:87:5D:9D:42:AF Connected: no
[CHG] Device 4C:87:5D:9D:42:AF Connected: yes
[CHG] Device 4C:87:5D:9D:42:AF Connected: no
[DEL] Device 4C:87:5D:9D:42:AF Bose NC 700 HP
[NEW] Device 4C:87:5D:9D:42:AF Bose NC 700 HP
[CHG] Device 4C:87:5D:9D:42:AF Connected: no
[DEL] Device 4C:87:5D:9D:42:AF Bose NC 700 HP
[NEW] Device 4C:87:5D:9D:42:AF LE-Bose NC 700 HP
[CHG] Device 4C:87:5D:9D:42:AF TxPower: 4
[CHG] Device 4C:87:5D:9D:42:AF Name: Bose NC 700 HP
[CHG] Device 4C:87:5D:9D:42:AF Alias: Bose NC 700 HP

That was a few days ago. Updated OS via Yum, and it seems to work better.

Now at:

[root@jwesterd ~]# uname -a
Linux jwesterd.remote.csb 4.18.0-193.13.2.el8_2.x86_64 

[root@jwesterd ~]# modinfo bluetooth | grep ver
version:        2.22
description:    Bluetooth Core ver 2.22
rhelversion:    8.2
srcversion:     C1E5FD94B66FFFE03FCB76F
vermagic:       4.18.0-193.13.2.el8_2.x86_64 SMP mod_unload modversions 


Now I seem to be able to stop / start Bluetooth (from GUI), at least on output side.

When I pair the headset (output) with bluetooth, the mic (input) has to be manually set.

Once mic (input) is selected (Headphone Bose NC 700 HP), Profile is in "Headset Handsfree" mode which only provides static/noise over mono under "test speakers".
Picking on the profile reveals "High Fidelity Playback (A2DP Sink)" which enables the Right/Left 
Speaker Tests to work as expected. THen its all good!

Using Bluejeans parrot https://bluejeans.com/111/ as my test.

Comment 34 Ken Benoit 2020-09-02 15:28:15 UTC
I haven't been able to reproduce the situation initially reported against RHEL-8.2.0, even with the Anker SoundBuds Slim+ noted in comment 3. Adam, if you get a chance, could you try testing against a recent build of RHEL-8.3.0 and see if it fixes the issue for you? If this fixes it for you I will get this verified.

Comment 35 Ken Benoit 2020-09-16 18:10:56 UTC
It's been a couple of weeks and I haven't heard anything. If the fix doesn't work please reopen this bug. For now, I'm going to verify this as SanityOnly since I ran testing against RHEL-8.3.0-20200812.n.0 awhile back against numerous Bluetooth headsets and speakers and had no issue pairing, connecting, or playing audio through them.

Comment 38 errata-xmlrpc 2020-11-04 02:03:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (bluez bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4562

Comment 39 Ilkka Tengvall 2020-11-24 09:52:11 UTC
This problem affects RHEL8.3 still. Here's a fix that makes it work better. It's question of loading pulse audio bluetooth discovery module too early, so user doesn't have access to it. This solution helps me get the Bose QC35 to work, after I hammer the bluetooth connect button few times. But without this fix, there is no chance to get them working:

https://gist.github.com/freyes/dfc3f5232526a62bbc09adc816e0477d

"
Source: https://g751jy.wordpress.com/about/parrot-zik-bluetooth-headset/
        https://bbs.archlinux.org/viewtopic.php?id=194006
Cached: http://webcache.googleusercontent.com/search?q=cache:4stTobIXSD0J:https://g751jy.wordpress.com/about/parrot-zik-bluetooth-headset/+&cd=3&hl=en&ct=clnk&gl=us

    Bug and possible solution: actually I found a bug in that make the headset unusable, it seems that the pulse audio module: module-bluetooth-discover works only if started after the X11 session is up. So I have a workaround.

    Edit the file:

    /etc/pulse/default.pa

    and comment out (with an # at the beginning of the line) the following line:

    #load-module module-bluetooth-discover

    now edit the file:

    /usr/bin/start-pulseaudio-x11

    and after the lines:

       if [ x”$SESSION_MANAGER” != x ] ; then
            /usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null
        fi

    add the following line:

        /usr/bin/pactl load-module module-bluetooth-discover

    This way the Pulse audio’s Bluetooth modules will not be downloaded at boot time but after x11 is started.
"

Problem with it is that this gets overwritten in my laptop while RHEL pulls updates, and I need to manually fix it again.

Comment 40 Ilkka Tengvall 2020-11-24 10:30:02 UTC
I created a new bug: https://bugzilla.redhat.com/show_bug.cgi?id=1901027

Comment 41 gopal krishna tiwari 2020-11-24 10:57:23 UTC
(In reply to Ilkka Tengvall from comment #40)
> I created a new bug: https://bugzilla.redhat.com/show_bug.cgi?id=1901027

Thanks Ilkka for creating new BUG.

Gopal..


Note You need to log in before you can comment on or make changes to this bug.