Bug 1830406 - kube-sceduler-operator targetconfig controller uses legacy router configmap
Summary: kube-sceduler-operator targetconfig controller uses legacy router configmap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Maciej Szulik
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1833120 1833122
TreeView+ depends on / blocked
 
Reported: 2020-05-01 20:25 UTC by Daneyon Hansen
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1833122 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-scheduler-operator pull 246 0 None closed Bug 1830406: Have targetconfig controller use cm/default-ingress-cert 2020-06-24 01:33:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:45 UTC

Description Daneyon Hansen 2020-05-01 20:25:07 UTC
Description of problem:
kube-sceduler-operator uses the legacy cm/router-ca -n openshift-config-managed to build cm/serviceaccount-ca -n openshift-kube-scheduler. As with [1], kube-sceduler-operator should use cm/default-ingress-cert -n openshift-config-managed.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
N/A

Steps to Reproduce:
1.N/A

Actual results:
N/A

Expected results:
N/A

Additional info:
[1] https://github.com/openshift/cluster-kube-controller-manager-operator/pull/402

Comment 3 RamaKasturi 2020-05-14 10:24:56 UTC
Verified the bug with the payload below and i did not find any references to router-ca in audit logs for 4.5 cluster. 

[ramakasturinarra@dhcp35-60 cucushift]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-05-13-092431   True        False         21h     Cluster version is 4.5.0-0.nightly-2020-05-13-092431


Below are the steps followed to verify the bug:
==================================================
1) Install 4.5 cluster with latest build
2) oc project "openshift-kube-apiserver"
3) oc cp <kube-apiserver-pod-name>:/var/log/kube-api-server/audit.log /tmp/oc45.log
4) cat /tmp/oc45.log | grep "router-ca"
[ramakasturinarra@dhcp35-60 cucushift]$ cat /tmp/oc45.log | grep "router-ca"
[ramakasturinarra@dhcp35-60 cucushift]$ 

[ramakasturinarra@dhcp35-60 cucushift]$ cat /tmp/oc45.log | grep "default-ingress-cert" | wc -l
297

Based on that moving the bug to verified state.

Comment 4 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.