Bug 183046 - Reboot after install on separate partions boots in to old OS
Reboot after install on separate partions boots in to old OS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 14:11 EST by Bruno Wolff III
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 20:25:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2006-02-25 14:11:13 EST
Description of problem:
This may be a matter of perception rather than a bug.
I installed in FC5T3 on separate partions on a machine that already has FC4
installed. I asked for grub to be installed.
After the installation I rebooted the machine, but it booted using the FC4
copy of grub. I expected to reboot into FC5.
Previously I had used
root (hd0,0)
setup (hd0)
setup (hd1)
So that both halves of my raid one mirror would be set up to boot off the first
partition of the first hard drive.
After I rebooted and found myself in FC4, I was able to do the following to
boot into FC5 (though later I will do something different to allow for a choice):
root (hd0,2)
setup (hd0)
After this a reboot put me in to FC5T3.


Version-Release number of selected component (if applicable):


How reproducible:
I have only done one successful install of FC5T3 so far.

Steps to Reproduce:
1. Install FC5T3 using a separate partition from an existing bootable FC4
installation.
2. Reboot
3.
  
Actual results:
Boots in to FC4


Expected results:
Boots in to FC5T3


Additional info:
Comment 1 Jeremy Katz 2006-02-27 12:46:01 EST
Did you select to have grub installed on the MBR or on the partition?
Comment 2 Bruno Wolff III 2006-02-27 12:59:21 EST
I am not sure. I was already wondering about this, because I thought it might
be relevant, but couldn't remember for sure. My intent was to install it on
the MBR, but I might have forgotten that try (I had tried previuosly with
a bad DVD).
I can try again tonight and test both ways of doing it and see if it makes a
difference.
Comment 3 Bruno Wolff III 2006-02-27 23:27:50 EST
I did two reinstalls tonight and did not get a chance to specify that grub
should be setup on the MBR. I did install grub on a partition and had the new
installation
as the default (and only) boot option.
Maybe this has to do with the way I am installing.
Anaconda is detecting a previous installation of FC4. However I selected a
new install rather than an upgrade.
I also selected a custom disk layout.
The disks are already set up with 5 raid 1 partitions.
When doing the install
md0 was defined as /otherboot don't overwrite
md1 was defined as /boot format as ext3
md2 was defined as swap
md3 was defined as /otheros don't overwrite
md4 was defined as / format as ext3
md5 was defined as /home don't overwrite
grub was installed on md1 with a password.
I went into advanced options for grub but didn't select any other boot partitions.
After the install, rebooting went to FC4 which was previously setup to boot from
the MBR of hd0 with md0 (hd0,0) holding the grub directory.
Comment 4 Jeremy Katz 2006-03-02 20:25:07 EST
Peter fixed problems with RAID1 /boot not installing GRUB to the MBR and instead
always doing the partition a day or two ago

Note You need to log in before you can comment on or make changes to this bug.