Bug 1830730 - Add log messages for DNS query test
Summary: Add log messages for DNS query test
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha
Version: 4.4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.4.0
: 4.4.0
Assignee: Asaf Rachmani
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-03 14:12 UTC by Asaf Rachmani
Modified: 2020-08-04 13:28 UTC (History)
2 users (show)

Fixed In Version: ovirt-hosted-engine-ha-2.4.3
Doc Type: Bug Fix
Doc Text:
Previously, if the DNS query test timed out, it did not produce a log message. The current release fixes this issue: If a DNS query times out, it produces a "DNS query failed" message in the broker.log.
Clone Of:
Environment:
Last Closed: 2020-08-04 13:27:53 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:3246 0 None None None 2020-08-04 13:28:24 UTC
oVirt gerrit 108783 0 master MERGED network: Add log messages for DNS query test 2020-10-01 06:31:13 UTC

Description Asaf Rachmani 2020-05-03 14:12:26 UTC
Description of problem:
There is no log message to detect DNS queries timeout 

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.4.2-1.el8.noarch
ovirt-node-ng-image-update-placeholder-4.4.0-0.9.beta1.el8.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy hosted-engine
2. Add another host that can run the HE vm
3. Shutdown the network of the host
4. Check /var/log/ovirt-hosted-engine-ha/broker.log on the host

Actual results:
There is no log message to detect DNS queries timeout

Expected results:
Error log in broker.log to detect DNS queries failure

Comment 1 Nikolai Sednev 2020-05-19 14:12:17 UTC
[root@puma19 ~]# ifconfig enp5s0f1 down
[14801.900221] ovirtmgmt: port 1(enp5s0f1) entered disabled state

puma19 ~]# less /var/log/ovirt-hosted-engine-ha/broker.log |grep dns
Thread-1::WARNING::2020-05-19 17:04:55,112::network::120::network.Network::(_dns) DNS query failed: 
Thread-1::WARNING::2020-05-19 17:05:02,627::network::120::network.Network::(_dns) DNS query failed: 
Thread-1::WARNING::2020-05-19 17:05:09,642::network::120::network.Network::(_dns) DNS query failed: 

[root@puma19 ~]# less /var/log/ovirt-hosted-engine-ha/agent.log |grep dns
MainThread::INFO::2020-05-19 15:08:20,900::brokerlink::82::ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink::(start_monitor) Starting monitor network, options {'addr': '10.35.163.254', 'network_test': 'dns', 'tcp_t_address': '', 'tcp_t_port': ''}
ovirt_hosted_engine_ha.lib.exceptions.RequestError: brokerlink - failed to start monitor via ovirt-ha-broker: [Errno 2] No such file or directory, [monitor: 'network', options: {'addr': '10.35.163.254', 'network_test': 'dns', 'tcp_t_address': '', 'tcp_t_port': ''}]
MainThread::INFO::2020-05-19 15:08:31,431::brokerlink::82::ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink::(start_monitor) Starting monitor network, options {'addr': '10.35.163.254', 'network_test': 'dns', 'tcp_t_address': '', 'tcp_t_port': ''}

Tested on:
ovirt-hosted-engine-ha-2.4.3-1.el8ev.noarch
ovirt-hosted-engine-setup-2.4.4-1.el8ev.noarch
Linux 4.18.0-193.4.1.el8_2.x86_64 #1 SMP Fri May 15 15:02:51 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux release 8.2 (Ootpa)

Works for me just fine, moving to verified.

Comment 6 errata-xmlrpc 2020-08-04 13:27:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (RHV RHEL Host (ovirt-host) 4.4), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:3246


Note You need to log in before you can comment on or make changes to this bug.