Bug 1830841 - Update ApiEnd point to fetch CRDs for event sources in UI
Summary: Update ApiEnd point to fetch CRDs for event sources in UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 05:41 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unknown or Dynamic Event Sources must be After Ping Source (122.63 KB, image/png)
2020-05-09 07:22 UTC, Gajanan More
no flags Details
consoledeveloper user (116.49 KB, image/png)
2020-05-09 07:37 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5270 0 None closed Bug 1830841: updates api-endpoint to fetch event sources and update default sources 2020-06-24 01:34:05 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:34 UTC

Description Jaivardhan Kumar 2020-05-04 05:41:41 UTC
Description of problem: Currently fetching dynamic sources with making direct call to CRD with version `v1beta` based on label selector ducktype and it works only admin iser ,So need to Update ApiEnd point to fetch CRDs for event sources (api using CRD version "v1") i.e `api/console/knative-event-sources` and return Default Sources in order



Version-Release number of selected component (if applicable): 4.5


How reproducible: Always


Steps to Reproduce:
1. Install Serverless operator
2. Install Eventing operator/or create CR for knative Eventing
3. Check in network for API call

Actual results: Lists dynamic sources only for Kubeadmin and default sources for basic user


Expected results: Lists dynamic sources for all users


Additional info:

Comment 3 Gajanan More 2020-05-09 07:22:41 UTC
Created attachment 1686698 [details]
Unknown or Dynamic Event Sources must be After Ping Source

Comment 4 Gajanan More 2020-05-09 07:23:45 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-09-014245
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot
Marking this as verified

Comment 5 Gajanan More 2020-05-09 07:37:09 UTC
Created attachment 1686709 [details]
consoledeveloper user

Comment 6 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.