Bug 1830846 - Update apiGroup for knativeEventing as in serverless 1.7
Summary: Update apiGroup for knativeEventing as in serverless 1.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 05:55 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Apis (287.91 KB, image/png)
2020-05-18 06:08 UTC, Gajanan More
no flags Details
card (149.91 KB, image/png)
2020-05-18 06:09 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5271 0 None closed Bug 1830846: updates apiGroup for KnativeEventing to latest supported 2020-06-24 01:34:08 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:34 UTC

Description Jaivardhan Kumar 2020-05-04 05:55:40 UTC
Description of problem:
With serverless GA eventing is part of it and user need not install knative Eventing operator[0]
with this there is change in group for KnativeEventing it has been moved to operator.knative.dev but in eventing operator it's still eventing.knative.dev (this will be deprecated) in devConsole we are leveraging KnativeEventing for feature flagging so Eventing maynot be shown if eventing is installed as part of serverless 1.7 GA. So going forward we need to be supporting operator.knative.dev

Prerequisites (if any, like setup, operators/versions):
Install serverless 1.7 operator from operatorHub[0]

Steps to Reproduce:
1. Install serverless operator 1.7
2. follow doc [0]
3. can't see eventSources card in add flow

Actual results: EventSources card won't show up in add flow

Expected results: EventSources card should show up in add flow

Reproducibility (Always/Intermittent/Only Once): Always

Build Details:
Build number: 4.5.0-0.nightly-2020-04-30-023404

Additional info:
[0] https://access.redhat.com/documentation/en-us/openshift_container_platform/4.3/html-single/serverless_applications/index#serverless-getting-started

Comment 3 Gajanan More 2020-05-18 06:08:55 UTC
Created attachment 1689515 [details]
Apis

Comment 4 Gajanan More 2020-05-18 06:09:04 UTC
Created attachment 1689516 [details]
card

Comment 5 Gajanan More 2020-05-18 06:21:59 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.ci-2020-05-18-010023
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot
Marking this as verified.

Comment 6 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.