Bug 183085 - Can't start xDSL connection
Can't start xDSL connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 21:13 EST by Yves Bellefeuille
Modified: 2008-04-22 18:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yves Bellefeuille 2006-02-25 21:13:26 EST
I simply can't start an xDSL connection using system-config-network. Nothing
happens when I try to connect. I have no problems with Fedora 4.

I realize this is not too useful as a bug report without further details, but I
thought I should make it anyway, since the problem is so critical.

The only suggestion I can make is this. In Fedora 4, in system-config-network,
under the Hosts tab, I have the following. This doesn't appear under Fedora 5
test 3. I tried to add it, but the program didn't accept the changes:

IP      127.0.0.1
Name    localhost.localdomain
Aliases localhost
Comment 1 Yves Bellefeuille 2006-03-04 18:47:25 EST
I've found a work-around, but I wouldn't call it a solution.

I have an ADSL connection which I bring up as required. It uses my ethernet
connection eth0, which I also bring up as required; it isn't activated
automatically at boot-up.

I worked around my problem by having eth0 activate automatically at boot-up.
There's a one-minute wait as I see "Determining IP information for eth0", but
then I can later activate my ADSL connection.

This was much easier to handle in Fedora 4. Activating my ADSL connectiom after
boot-up did whatever was necessary to activate my ethernet connection.
Comment 2 Matthew Miller 2007-04-06 13:22:45 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 3 George Kivaria 2008-02-04 06:35:00 EST
This is on Fedora 8 LIVE, i created a PPoE connection, managed to browse on the 
first time, then when i came the next day, i can no longer access my xdsl 
connection, attached is the dump: ** (PLEASE HELP!  i do not know much about 
Linux since this is my first time using this system) **.
Bug Dump follows:
Component: system-config-network
Version: 1.4.3
Summary: TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for 
int() with base 10: 'None'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 
277, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 
289, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 
780, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 
692, in load
    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])
ValueError: invalid literal for int() with base 10: 'None'

Local variables in innermost frame:
hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0x94cc98c>
i: 1
self: HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=b44
HardwareList.Ethernet.eth0.Description=Broadcom Corporation BCM4401-B0 100Base-
TX
HardwareList.Modem.Modem0.Status=configured
HardwareList.Modem.Modem0.Name=Modem0
HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem
HardwareList.Modem.Modem0.Type=Modem
HardwareList.Modem.Modem0.Description=Generic Modem

isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x96d1d4c>
hw: Hardware.Status=configured
Hardware.Name=Modem0
Hardware.Modem.DeviceName=/dev/modem
Hardware.Type=Modem
Hardware.Description=Generic Modem

dev: Modem0
wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0x96d1fec>
END OF DUMP.
Comment 4 Fedora Update System 2008-04-07 10:34:31 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-04-09 01:19:49 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 6 Fedora Update System 2008-04-22 18:38:36 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.