Bug 1830878 - D/DC should not be a valid drop target for Move Sink of an Event Source
Summary: D/DC should not be a valid drop target for Move Sink of an Event Source
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 08:07 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5272 0 None closed Bug 1830878: event source connector drop target should only be knative service 2020-06-24 01:34:08 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:34 UTC

Description Jaivardhan Kumar 2020-05-04 08:07:18 UTC
Description of problem:
When trying to move and Event Source sink, if you drop on an event source, it realizes it's an invalid target. But if you drop on a D/DC, it doesn't realize it, and then deletes the connector

Version-Release number of selected component (if applicable): 4.5


How reproducible: Always


Steps to Reproduce:
1. Install Serverless/Eventing operator
2. GO to DevConsole -> add -> create a knative service as part of container image
3. GO to DevConsole -> add -> create a Deployment/DeploymentConfig as part of container image
4. GO to DevConsole -> add -> create an eventSource and sink to knative service created in step2
5. Try drag and drop connector from eventSource to service to another deployment/DeploymentConfig 

Actual results: if you drop on a D/DC, it doesn't realize it, and then deletes the connector


Expected results: if you drop on a D/DC, it shouldn't realize it and no actions should be taken i.e sources connector should still sink to knative service


Additional info:

Comment 3 Gajanan More 2020-05-09 07:28:15 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-09-014245
Browser: Google Chrome Version 81.0.4044.129
Marking this as verfied

Comment 4 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.