Bug 1830887 - Upstream removal of reflect based conversion
Summary: Upstream removal of reflect based conversion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: David Eads
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 08:43 UTC by Michal Fojtik
Modified: 2020-07-13 17:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-apiserver pull 96 0 None closed Bug 1830887: fix the rollback generator scheme usage 2020-06-24 01:34:11 UTC
Github openshift openshift-apiserver pull 97 0 None closed Bug 1830887: fix projectrequestlimit conversion 2020-06-24 01:34:11 UTC
Github openshift openshift-apiserver pull 98 0 None closed Bug 1830887: fix test scheme for templates 2020-06-24 01:34:11 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:34:34 UTC

Description Michal Fojtik 2020-05-04 08:43:23 UTC
Description of problem:

https://github.com/kubernetes/kubernetes/pull/90018 switches off the path for default conversions - from now on, only explicitly registered conversions work.

https://github.com/openshift/openshift-apiserver/pull/95 tried to pull this fix so we can prepare ourself for next level of kube.

This BZ is an umbrella for the PR's fixing various conversion offenders in OpenShift.

Version-Release number of selected component (if applicable):

4.5

Additional info:

There is nothing QA can test here, other than regular regression tests.

Comment 3 Xingxing Xia 2020-06-05 10:36:48 UTC
Checked above merged PRs and the upstream link about what they did. The resources involved are across subteams, e.g. DC, template. Per comment 0, QE subteams have done regression tests daily, no issue related found. Moving to VERIFIED.

Comment 4 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.