Bug 183090 - no match for hp 5940 printer in printer setup
no match for hp 5940 printer in printer setup
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-25 23:32 EST by eric peabody
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 10:49:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric peabody 2006-02-25 23:32:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The same as bugs 162506 176493 176709.  Normally I would not report this, but saw that Tim asked someone else who reported a problem to submit a separate bug report.  I get:

[root@localhost ~]# printconf-gui &
[1] 2986
[root@localhost ~]# No match for USB device:
  mfr "HP"
  model "Deskjet 5900 series"
  desc "5940"
  cmdset "MLC,PCL,PML,DW-PCL,DESKJET,DYN"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

I just select HP 990c, and it seems to work. 


Version-Release number of selected component (if applicable):
foomatic-3.0.2-19

How reproducible:
Always

Steps to Reproduce:
1.as root, enter the command in the description above.
2.if the message doesn't appear in a minute or less, try to add a printer or edit the 5940.
3.
  

Actual Results:  see the extract in the description.

Expected Results:  Nothing.  This message doesn't prevent adding or editing.  But you do have to name some other model of printer whose ppd is close enough to the one you really have to do what you want to.

Additional info:

I downloaded a ppd for the hp5940.  Is there some way foomatic could look for something like that, ask the user if it's ok to use it, and modify the list to refer to it?  There will be new printers  al the time.  There should be a way to generate ppds automatically, or atleast a way for the user to write one and try it at our own risk.
Comment 1 Tim Waugh 2006-02-27 10:49:11 EST
Thanks -- this is different from the other bugs because it is a different
printer model.  We need to collect those 'Device ID' strings in order for that
model to be automatically detected in future.

I've added the Device ID strings from your report into the linuxprinting database.

In the meantime, you can use 'Actions->Import PPD...' from the menu to use the
PPD you have downloaded.

Note You need to log in before you can comment on or make changes to this bug.