Bug 183098 - x86_64 fails, i386 succeeds
x86_64 fails, i386 succeeds
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 02:23 EST by Michael Schwendt
Modified: 2015-05-04 21:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.5.4a-37.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-12 10:37:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
May or may not be a failing testcase... (198 bytes, text/plain)
2006-03-01 12:20 EST, Petr Machata
no flags Details
Compressed version... (213 bytes, application/x-gzip)
2006-03-01 12:24 EST, Petr Machata
no flags Details

  None (edit)
Description Michael Schwendt 2006-02-26 02:23:20 EST
Encountered the following discrepancy between the results flex gives
on x86_64 compared with i386:

x86_64: "unrecognized rule"
http://buildsys.fedoraproject.org/logs/fedora-development-extras/5261-aide-0.11-1/x86_64/build.log

i386: successful and silent
http://buildsys.fedoraproject.org/logs/fedora-development-extras/5261-aide-0.11-1/i386/build.log

Even if something in the flex input file may be broken, results ought
to be the same on both architectures. This is suspicious.
Comment 1 Petr Machata 2006-03-01 11:14:37 EST
Hi... I'm digging into the problem, and I'm unable to reproduce it.

I've copied the problematic file (conf_lex.l) out of aide. The lines that are
reported as problematic contain named definitions of non-english characters, and
this is notorious source  of problems, prticularly in relation to UTF-8. So
there *might* be an error.

However, with the commandline from log, I can't reproduce the error.  This
  flex -l -Pconf -oconf_lex.c my-copy-of-conf_lex.l
just passes, both on i386 and on x86_64.  I tried it with FC-4 flex version,
although not on FC-4. Can you confirm that the problem really exists, e.g. by
trying to send the file explicitly through flex, or trying to rebuild the package?
Comment 2 Michael Schwendt 2006-03-01 11:51:49 EST
Well, the problem did exist. Else it would not be in the logs.
But let's see. I just requeued the build job:
http://buildsys.fedoraproject.org/build-status/job.psp?uid=5261

> I tried it with FC-4 flex version, although not on FC-4.

This is about Rawhide, though.
Comment 3 Petr Machata 2006-03-01 12:19:30 EST
Oops, sorry, that was the *other* flex bug that was against FC-4.
Well, actually I tried it also with rawhide, and the results were the same...
the thing just worked.

Anyway... I will attach what might be small (although probably not minimal)
testcase. Could you please try to pass it through flex and see if it fails?
Comment 4 Petr Machata 2006-03-01 12:20:48 EST
Created attachment 125481 [details]
May or may not be a failing testcase...
Comment 5 Petr Machata 2006-03-01 12:24:14 EST
Created attachment 125482 [details]
Compressed version...

Maybe I'd rather compress it so that the non-us letters don't get screwed
through browsers etc.
Comment 6 Michael Schwendt 2006-03-01 15:38:48 EST
I do not have a Fedora x86_64 box to test with.

The requeued build attempt failed in the same way only on x86_64.
No problem for i386 and ppc. Logs here:
http://buildsys.fedoraproject.org/build-status/job.psp?uid=5261

AIDE used to build fine for x86_64 (e.g. FC-4), albeit in an older
version, 0.10. Since then the developers have applied only this
change in the flex input file:

--- old/conf_lex.l      2003-01-16 11:37:34.000000000 +0100
+++ new/conf_lex.l      2005-07-02 01:10:43.000000000 +0200
@@ -6,7 +6,7 @@
 L      [a-zA-Z<F6><E4><FC><DF><E5><D6><C4><DC><C5>0-9_]
 D      [0-9]
 
-PC     \\[0-3][0-7][0-7]
+PC     \\[^\n]
 
 EX      [" "\t]*
 
Comment 7 Michael Schwendt 2006-03-02 07:32:56 EST
As another test, I built FC4's aide (which is in the Fedora Extras 4
x86_64 repository) for Rawhide. Same results. Failure on x86_64, success
on i386:

http://buildsys.fedoraproject.org/build-status/job.psp?uid=5719

x86_64:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/5719-aide-0.10-3.fc5/x86_64/build.log

i386:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/5719-aide-0.10-3.fc5/i386/build.log
Comment 8 Petr Machata 2006-03-02 08:03:43 EST
Hmm, it really *is* reproducible on fedora box... there's something nasty. I'm
looking inside...
Comment 9 Petr Machata 2006-03-02 11:22:38 EST
The problem should be gone in tomorrow's rawhide (flex-2.5.4a-37.3). I tried to
build aide with updated flex package, and it worked. Give it a shot, it should
be ok.
Comment 10 Michael Schwendt 2006-03-07 04:57:43 EST
Your %changelog entry should have read March 2nd or 3rd, not Feb 10th:

* Fri Feb 10 2006 Petr Machata <pmachata@redhat.com> - 2.5.4a-37.3
- rebuilt, no changes inside. In hunt for #183098

I was querying flex changelog and was waiting for an update. ;)
Anyway, I've just requeued build job 5261, but the rawhide ppc repository
is broken currently, so I need to retry later.
Comment 11 Michael Schwendt 2006-03-07 14:34:09 EST
This time it failed on ppc, but succeeded on x86_64 and i386:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/5261-aide-0.11-1/
Comment 12 Petr Machata 2006-03-08 07:53:14 EST
I added failing case test into build process, so this time, flex should
*finally* be ok, the test passed an all platforms.
Changelog date was fixed.
Comment 13 Petr Machata 2006-03-08 08:18:23 EST
Hm, and introduced new changelog date bug: Fri Mar 8. Long live cut'n'paste.
Comment 14 Michael Schwendt 2006-03-12 10:37:53 EST
Fixed. Thanks!

http://buildsys.fedoraproject.org/build-status/job.psp?uid=5261

Note You need to log in before you can comment on or make changes to this bug.